TECHNICAL NOTE

ADVANCED DIAGNOSTICS IN EMERSON ENVIRONMENT
# Table of Content

1. Introduction ........................................................................................................................................................ 3
2. Components of the Advanced Diagnostic System .............................................................................................. 4
   2.1 The Advanced Diagnostic Module HD2-DM-A............................................................................................ 4
   2.2 The Power Hub Diagnostic Bus .................................................................................................................. 4
       2.2.1 RS 485 Bus: Connection cable .............................................................................................................. 4
       2.2.2 Diagnostic Gateway ............................................................................................................................... 4
   2.3 The Diagnostic Manager Software ............................................................................................................. 4
       2.3.1 Diagnostic Manager – Basic Edition...................................................................................................... 4
       2.3.2 Diagnostic Manager – Professional Edition ........................................................................................... 5
   2.4 The FieldConnex Diagnostic Server ........................................................................................................... 5
       2.4.1 Basic Functions ..................................................................................................................................... 5
3. Overview of Integration into Emerson Environment ............................................................................................ 6
   3.1 The Pepperl+Fuchs ADM Project Builder Emerson .................................................................................... 6
   3.2 AMS Alert Adapter ...................................................................................................................................... 7
4. Software Installation Process in Chronological Order ......................................................................................... 9
5. ADM Project Builder Emerson ........................................................................................................................... 10
   5.1 Setup FieldConnex Diagnostic Manager Topology ................................................................................... 10
6. Setup of Emerson’s AMS® Environment ......................................................................................................... 19
   6.1.1 Setup AMS® Alert Adapter ................................................................................................................... 19
   6.1.2 Create a Linked Application with the Generic Application Launcher ................................................... 22
6.2 Setup Alert Monitor for Advanced Diagnostic .......................................................................................... 28
7. Alarm Workflow Example .................................................................................................................................. 29
   7.1 Alarm Message Overview ......................................................................................................................... 31
8. Change of Topology, Add or Delete Segments .................................................................................................. 32
   8.1 How to change Topology ......................................................................................................................... 32
1 Introduction

This document describes how the Advanced Diagnostic Module is integrated into Emerson environment. The Advanced Diagnostic Module is a comprehensive measurement tool for the fieldbus physical layer and plugs into the motherboards of FieldConnex Power Hub product family. It is well suited for commissioning, online monitoring and maintenance. Passive input circuits leave the physical layer untouched, avoiding alteration of the signal. The Advanced Diagnostic Module HD2-DM-A is a plug-in module for the FieldConnex Power Hub.

The module provides the exact segment and individual device data needed for detection of gradual or sudden changes in the fieldbus physical layer. Intermittent segment malfunctions can be traced.

The Diagnostic Manager software is the user interface. It displays all measurement values with fast screen updates in the control room. The Commissioning Wizard generates automated reports; the software displays clear-text messages for troubleshooting of out-of spec behavior. It is based on FDT/DTM technology and needs a framework such as PACTware™ to run.

![Advanced Diagnostic Module](image)

Figure 1: Advanced Diagnostic Module plugged onto a FieldConnex Power Hub

This solution requires the following hard- and software components:

- Advanced Diagnostic Module HD2-DM-A
- Advanced Diagnostic Gateway Module KT-MB-GT2AD
- Diagnostic Manager Version 2.0.3.* or higher
- PACTware™ 4.0 or higher
- Emerson AMS® Suite Version 10.5 or higher (for alarm integration)
- Emerson DeltaV Suite Version 10.0 or higher (for project import)
- A dedicated FF-Device

The following further auxiliary software is required for operation:

- .NET framework 2.0.
  This software is required for PACTware™ operation.
  This software is available at Microsoft or Pepperl+Fuchs web site or included in the Diagnostic Manager CD-ROM package.

The following documentation is additionally recommended for easy installation and commissioning:

- Quick Installation Guide Advanced Diagnostics
- Manual Advanced Diagnostic Solutions

All documents are available for download at www.pepperl-fuchs.com.
2 Components of the Advanced Diagnostic System

Performing Advanced Diagnostics requires different components for proper operation. Components and their functions are described in this chapter.

2.1 The Advanced Diagnostic Module HD2-DM-A

The Advanced Diagnostic Module HD2-DM-A mounts on Power Hub motherboards hosting the fieldbus power supplies. Its task is to monitor all physical properties of the system platform, the Fieldbus segments and connected Field Devices. The preferred type of usage is lifecycle support, long term supervision and proactive service of complete Fieldbus plants or parts of it with extended demands on reliability and continuity.

2.2 The Power Hub Diagnostic Bus

The Diagnostic Bus is part of the Power Hub system and allows the connection of multiple Advanced Diagnostic Modules to the FieldConnex Diagnostic Server (FDS). The bus is operating independent of the monitored Fieldbus. Optimum monitoring of the Fieldbus communication is assured by its separate connection without loading the communication between the field devices and the instrumentation and control system with additional data traffic. The maximum number of 31 diagnostic modules can be connected to one Diagnostic Bus.

2.2.1 RS 485 Bus: Connection cable

The Diagnostic Bus is RS 485 interface based and looped from Power Hub to Power Hub. Adjacent Power Hub motherboards can be connected with the ACC-MB-HDC connection cable. Greater distances are bridged with simple, individual cables. A shielded cable is not required. The overall length of the bus should not exceed 30 m. Cause of the short distance a bus termination is not needed.

2.2.2 Diagnostic Gateway

The Diagnostic Gateway bridges the Diagnostic data from Ethernet to RS 485 and vice versa. It is typical to have Ethernet on top of the Cell and Fieldbus network running as high level network. This is why we recommend using such a device to make the integration into the existing structures as effortless as possible.

2.3 The Diagnostic Manager Software

The Diagnostic Manager is the powerful software tool, which can configure process and visualize the functions at the Advanced Diagnostic Module (ADM). The Diagnostic Manager is DTM based and can run in PACTware™ or any other FDT compatible and proven framework.

2.3.1 Diagnostic Manager – Basic Edition

The Basic Edition is a free version. It can be used with the mobile DM-AM module and with the stationary Power Hub mountable HD2-DM-A module. Up to 3 HD2-DM-A modules can be configured and monitored. The basic version is not fully featured but is made for immediate system setup and monitoring. Functions of the Basic Edition are:

- Online parameterization
- Offline parameterization
- Download of the configuration to the diagnostic modules
- Printing the project
- Saving the project

The software can be downloaded from www.pepperl-fuchs.com.
2.3.2 Diagnostic Manager – Professional Edition

A software license is required for the Professional Edition. The Professional Edition offers all value-added features such as the oscilloscope, commissioning wizard, high-speed segment monitoring, history data export and many more. Diagnostic Managers for the HD2-DM-A and the DM-AM are described in detail in their respective data sheets and manuals.

2.4 The FieldConnex Diagnostic Server

2.4.1 Basic Functions

The FieldConnex Diagnostic Server (FDS) as part of the Diagnostic Manager is a software which coordinates the access of data between the diagnostic modules and the Diagnostic Manager. The FDS is installed on the PC the diagnostics buses are physically connected or assigned to. The Diagnostic Manager and the FDS can run simultaneously on the same PC or be installed separately on different PCs.
3 Overview of Integration into Emerson Environment

The integration philosophy of Advanced Diagnostics into an Emerson environment is based on two main software tools developed from Pepperl+Fuchs: the AMS Alert Adapter and the ADM Project Builder Emerson.

Both tools are independent from each other, so FieldConnex Advanced Diagnostic can be implemented within a wide range of different Emerson system environments.

Use both Pepperl+Fuchs tools if AMS and DeltaV are implemented within your plant for optimal Advanced Diagnostic integration.

Following both tools the AMS Alert Adapter and the ADM Project Builder Emerson are described in detail.

3.1 The Pepperl+Fuchs ADM Project Builder Emerson

The Pepperl+Fuchs ADM Project Builder Emerson takes-over fieldbus topology information of the DeltaV to automatically generate a FieldConnex Diagnostic Manager project in PACTware™ and to configure the FDS with current data.

The ADM Project Builder Emerson software contains the complete set of rules to match the DeltaV topology onto the FieldConnex Advanced Diagnostic topology, thus enables an efficient work with the Advanced Diagnostic Modules. Addressing and tagging in the Diagnostic Manager and FDS is also performed automatically based on the information taken out of DeltaV. Find the basic mapping conditions below.

**DeltaV basic mapping conditions:**

- Each Controller (node) contains up to 64 FF H1 cards
- Each FF H1 card has two ports
- Each port is connected to one fieldbus segment

**FieldConnex Advanced Diagnostic basic mapping conditions**

- Each FDS port is able to manage up to 32 Advanced Diagnostic Modules; this is a fixed limit which the ADM Project Builder Emerson takes into account during the mapping process.
The figure above shows the interconnection of the hard and software components. Each FF-H1 card of an Emerson controller is connected to two segments on the Power Hub motherboard which contains one Advanced Diagnostic Module (ADM). Depending on the type of motherboard up to 4 segments in redundant configuration are provided and monitored by the ADM. The Power Hub motherboards are series connected (Diagnostic Bus) via a Diagnostic Gateway and Ethernet to the FieldConnex® Diagnostic Server (FDS).

Because the Emerson DeltaV Controller topology differs from the FieldConnex® Advanced Diagnostic topology the P+F ADM Project Builder Emerson was developed for the automatically mapping. It takes over the current node and tag information from DeltaV during the setup process and prepares them for the FDS. This means during work within the Diagnostic Manager original segment and tag information is shown for optimized device overview.

### 3.2 AMS Alert Adapter

The AMS Alert Adapter builds the connection between the Emerson AMS Suite and the FieldConnex® Diagnostic Server. This connection provides the powerful Diagnostic Manager alarm handling straight out of the AMS® Alert Monitor.

AMS Alert Adapters’ way of working:

1. A dedicated FF device located within the plant is operating as an implement to transfer diagnostic information into the AMS® Alert Monitor. A physical device is needed since this is able to configure devices recognized by a network scan only.

2. A custom software component, called AMS® Alert Adapter links the common diagnostic components into the AMS® environment, respectively into the dedicated FF devices alarm handler.

3. The Diagnostic Manager launched straight from the AMS® Alert Monitor, provides detailed diagnosis information for maintenance personnel.
To integrate Advanced Diagnostics in AMS® environment a FF device (should not be used for other purposes) has to be installed in the field and configured within the AMS® environment like a common FF device. The AMS® Alarm Adapter projects all status and alarm messages onto this dedicated device.

After proper configuration the Diagnostic Manager can be started directly from AMS® Alert Monitor. For this purpose it has to be defined as a linked application in AMS®. Next to the manager application itself project file has to be created at PACTware™ it shall come up with when it is started from AMS® in order to perform Advanced Diagnostics on the correct fieldbus segments.

Fieldbus commissioning and monitoring is easily granted within your familiar environment. Upcoming Fieldbus alarms can be diagnosed in any detail and allows you to find the source of error easily. Advanced Diagnostics respectively the Diagnostic Module gives you enough time to look for the source of error in the Diagnostic Manager since an alarm is raised already even if just a tolerable maintenance limit is exceeded.

Figure 2: Hardware und Software Integration of the Advanced Diagnostics in Emerson environment
4 Software Installation Process in Chronological Order

The order of software installation steps is as follows:

1. Install .NET framework, PACTware™ and FieldConnex® Diagnostic Manager (for further information please refer to the Quick Installation Guide FieldConnex® Advanced Diagnostics)

2. Install Diagnostic Gateway (for further information please refer to the manual)

3. Make sure that AMS® Suite 10.5 or higher is installed

4. Install AMS Alert Adapter, required for installations with Emerson AMS® Suite

5. Install ADM Project Builder Emerson, required for installations with DeltaV

6. Install AMS® Application Launcher included on CD2 of the AMS® install package, directory: \Supplemental_Tools\GenericApplicationLauncher\Setup.exe

Be sure to have administrator rights on your PC in order to let the applications make their proper registry changes.
5 ADM Project Builder Emerson

5.1 Setup FieldConnex Diagnostic Manager Topology

To get a general idea of the integration process the required steps are listed below in short:

- Export of the DeltaV Control Network topology
- Import of the DeltaV Control Network topology into the ADM Project Builder Emerson. Some specific files will be created for Diagnostic Manager configuration.
- Configuration of PACTware™, Diagnostic Manager and FDS

Work steps:

1. Open Emerson DeltaV Explorer

![Emerson DeltaV Explorer](image1.png)

2. Do right mouse click on Control Network and choose [Export]

![Right mouse click on Control Network](image2.png)

3. Enter file name and save file

![Enter file name and save file](image3.png)
4. Open ADM Project Builder Emerson software

5. Choose [Import DeltaV file]
6. Open the file created within step 3

7. Merge Result window appears. Press [OK].
8. Drag & Drop NODE1 to the FDS node

9. Configure Diagnostic Gateway Address

10. Drag & Drop NODE2 to the Diagnostic Gateway

11. Drag & Drop NODE3 to the FDS node to create a new Diagnostic Gateway port. Or Click on the icon to create a COM port and move NODE onto it.
12. Your topology may look like above. The ADM Topology Preview window in the bottom right corner shows the result of the mapping process. You can see where the nodes are located and that the actual tag names of DeltaV are used within the Diagnostic topology.

13. Choose [File] > [Export FDS configuration]

15. Choose [File] > [Save project file]. Choose directory and filename of current ADM Project Builder Emerson configuration and press [Save].

16. The following files (step 13 and step 15) are now created and saved to the chosen directory:

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Config.XML</td>
<td>Interchange format for PACTware™ import</td>
</tr>
<tr>
<td>Report.pdf</td>
<td>Mapping table of ADM and DeltaV topology for field installation</td>
</tr>
<tr>
<td>Projectbuilderexample.epb</td>
<td>Saved ADM Project Builder Emerson configuration file.</td>
</tr>
</tbody>
</table>

Saving these files makes you able to do iterative configuration changes without performing the whole setup again.

17. Open PACTware™
18. Choose [Extras] > [Options]. Set value: **Use memory-optimized project management**

19. Choose [Window] > [Device Catalog]. Drag&Drop **FieldConnex Diagnostic Server** to the Host PC node within the Project window.

21. Right mouse click on the FDS node and choose [Connect]
22. Right mouse click on the FDS node and choose [Additional functions] > [Topology Scan and Import]

23. Browse to the output folder of step 13
24. Choose the Config.xml file

25. Press Next and the Wizard will lead you through the creation of the PACTware™ Diagnostic Project.

26. Choose [File] > [Save as...]. Choose directory and filename of the current PACTware™ project and press [Save].
6  Setup of Emerson’s AMS\textsuperscript{R} Environment

To get a general idea of the integration process the required steps are listed below in short:

1. Setup the P+F AMS Alert Adapter
2. Configuration of the generic Application Launcher
3. Setup Alert Monitor for FieldConnex Advanced Diagnostics

To integrate Advanced Diagnostics in AMS\textsuperscript{R} a dedicated FF-device has to be installed in the field and configured within the AMS\textsuperscript{R} environment.

6.1.1  Setup AMS\textsuperscript{R} Alert Adapter

The AMS\textsuperscript{R} Alert Adapter connects the dedicated FF-device to the FieldConnex\textsuperscript{R} Diagnostic Server (FDS). It runs as a background service.

- Server-machine: Execute DCOM-Wizard only for the intended user, anonymous access is not necessary.
- Client-machine: AMSAlertAdapterService has to run under intended user.
- Client-Firewall: Add TCP-Port 135 and the AMSAlertAdapterService to the Firewall-Exceptions.

6.1.1.1  Set up FDS for remote access:

1. Open Pepperl + Fuchs FDS Control Center.
2. Choose [Settings…]
3. Set check-box [Adjust firewall to allow remote access:]
5. Enter user
6. Disable check-box [Allow Anonymous access]
7. Set check-box [Execute FDS under the selected account]
8. Press [Next]
9. Enter password of remote user
10. Restart the PC
11. Make sure that the AMSR Alert Adapter is running.
12. Double click on the icon within the task bar
13. AMSR Alert Adapter configuration window opens.
14. Enter AMSR Tag (Tag of the dedicated FF device) and location of the pc the FDS is running on.
If FDS is running on the same PC enter localhost.
If FDS is running on a remote PC you need to enter the IP address or DNS.

**Note**
Do not connect the dedicated FF device to the FDS before installation and commissioning of all segments and devices is completed. Otherwise performance problems may happen.

For commissioning purposes use PACTware™ and the Diagnostic Manager Commissioning Wizard function.

15. Press [Connect]
6.1.2 Create a Linked Application with the Generic Application Launcher

To be able to start the Diagnostic Manager from inside AMS® a Snap-On has to be created. Close the AMS® Device Manager and start the Generic Application Launcher by running the AppLauncher.exe in the “...\bin” subdirectory of AMS® installation directory. Use again the username “admin” without a password to login.

If AppLauncher.exe is not available within this directory install the application from CD 2 of the AMS® suite package.

There are two different options to configure the application launcher:

1. AMS® is blocked and cannot be used while the Diagnostic Manager is executed.
2. Diagnostic Manager and AMS® can be use in parallel.

**Option 1: AMS® is blocked and cannot be used while the Diagnostic Manager is executed**

1. In the [Application] Tab enter the Snap-On's name to be displayed later in AMS®.
2. Fill out the [help text] box with an expressive string for Diagnostic Manager's function like FieldConnex Diagnostic Manager.
3. Enter the path “C:\Program Files\PACTware Consortium\PACTware 4.0\App\PACTware.exe” of the program to be executed into the box [Path] and append to it the path and name of the project's file to be loaded automatically when started.

The Diagnostic Manager is not standalone software and is embedded into the PACTware™ software always. This is why you have to specify PACTware™ as initial software to be loaded and to enter the path of the application. Following you will find an example how this string could look like:

![Application Launcher Configuration](image)
4. Enter path of the PACTware™ project file at Argument 1 of the Command Line Tab. This PACTware™ project file must be created before e.g. during commissioning with the ADM Project Builder Emerson if DeltaV is used see chapter 5.1 work step 26.
Option 2: Diagnostic Manager and AMS can be use in parallel.

1. Enter in the [Application] Tab the Snap-On’s name to be displayed later in AMS®.

2. Fill out the [help text] box with an expressive string for Diagnostic Manager’s function like FieldConnex Diagnostic Manager.

3. Enter the path of the program to be executed into the box [Path] and append to it the path and name of the project’s file to be loaded automatically when started.

4. Enter cmd.exe as path.

5. On the Command Line Tab enter the following Arguments:
   - **Argument 1:** /C start “Diag Manager”
   - **Argument 2:** Path to Pactware, e.g. “C:\ Program Files\ PACTware Consortium\ PACTware 3.0\ App\ PACTware.exe”
   - **Argument 3:** The path to the PACTware™ project file must be entered at Argument 1 of the Command Line Tab. This PACTware™ project file must be created before e.g. during commissioning with the ADM Project Builder Emerson if DeltaV is used see chapter 5.1 work step 26.

Make sure that Argument 2 and 3 are enclosed by quotation marks and “Add a space before argument” is activated.
6. Open PACT\textcopyright ware

7. Choose [Extras/Options]

8. Set check-box [PACTware may only be started once]
9. Switch to the [Device Types] tab to the right and select the device you have configured as the dedicated FF device (this example uses the Rosemount 3244MV device).

10. Move the FF device into the [Associated Device Types] list to the left using the single “arrow to left” button in the middle of the screen. In addition the list box: [Add this linked application to the Tools main menu within AMS Device Manager] must to be activated to ensure that this tool is visible later in AMS Suite.
11. Choose [File/Save] to save the configuration and terminate the Generic Application Launcher.

12. To start the Diagnostic Manager do right mouse click on the device and choose [SNAP ON/Linked Apps] > [Fieldconnex Diagnostic Manager].
6.2 Setup Alert Monitor for Advanced Diagnostic

To display diagnostic information from the Advanced Diagnostic Module the dedicated FF device has to be configured within the AMS® Alert Monitor first:

1. Open Alert Monitor: [View] > [Alert Monitor]

2. Press [Configure], Device Selection List will open

3. Select the dedicated FF device from the list and confirm with [OK]
7 Alarm Workflow Example

This example shows the benefits of both P+F tools within an Emerson environment containing the AMS® Suite and also DeltaV components. The AMS Alert Adapter provides the diagnostic information to the AMS® Suite and the ADM Project Builder Emerson is used to show DeltaV segment tags inside the Diagnostic Manager.

Following an exemplary workflow is shown you have to run through if an alarm happens.

If an alarm value is exceeded the dedicated FF device pops up in the Alert Monitors Active Alert List. Within the Description table cell you find information about the segment and the status of the current alarm messages (see 7.1).

To get a detailed view start the Diagnostic Manager as follows:

1. Do right mouse click on the dedicated FF device and choose [SNAP-ON/Linked Apps] > [FieldConnexDiagnostic Manager]
2. Connect the Host PC: right mouse click [Connect]

3. Do right mouse click on the FDS and choose [Diagnostics]

4. Now an overview of all segments with the diagnostic information is shown. To directly reach the detailed view press [Open]
5. Now a details list of alarms occurred for the segments and corresponding nodes

7.1 Alarm Message Overview

How the alert string is build up:

<table>
<thead>
<tr>
<th>Meaning: Display</th>
<th>AMS Alert Type</th>
<th>Segment</th>
<th>Alarm Status</th>
<th>Message ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAINT</td>
<td>Segment 1</td>
<td>Out of Specification</td>
<td>2007</td>
<td></td>
</tr>
</tbody>
</table>

The possible alarm statuses are:

- Good
- Maintenance required
- Out of Specification
- Hardware error
- Communication error
- Segment disabled

For more detailed information please refer to the manual Advanced Diagnostic Solutions.
8 Change of Topology, Add or Delete Segments

8.1 How to change Topology:

1. Export of the DeltaV Control Network topology (see chapter 5.1).

2. Load previously used project into ADM Project Builder Emerson.

3. Import new DeltaV Control Network topology into ADM Project Builder Emerson.

4. Assign the new Node's to Ports, remove unused Ports

5. Export the new FDS Configuration

6. Load previous used Pactware Project

7. Right mouse click on the FDS node and choose [Connect]

8. Right mouse click on the FDS node and choose [Additional functions] > [Topology Scan and Import]
9. Load the new FDS Configuration with the “Read from File” capability into the FDS-DTM (and allow to “Set the new Topology to the FDS server”)

10. Choose the new Config.xml file

11. At next step occurs a change-preview, single ADM’s can be de-selected

12. After finishing the import, you’ll get a change-summary

13. Choose [File] > [Save] to Save the current Pactware Project.

The Topology change is completed now and can be used.