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1. Introduction 
This document describes the principles of the Pepperl+Fuchs Advanced 
Diagnostic integration into the Yokogawa Plant Resource Manager Software 
(PRM).  
It also contains all information required for engineering, and commissioning of the 
Pepperl+Fuchs components and to integrate them into the Yokogawa 
environment. It qualifies the user to do the first steps with PRM and the Advanced 
Diagnostic tools. However, this document does not cover the complete 
functionality of the Pepperl+Fuchs Advanced Diagnostic solution. To learn more 
about the powerful possibilities and usage of all functions, refer to the following 
documentation found at www.pepperl-fuchs.com: 
￭ Manual Advanced Diagnostic Solutions 

￭ Quick Start Guide Advanced Diagnostics 

About the Advanced Diagnostic Module 
The Advanced Diagnostic Module (ADM) is specially designed to analyze signal 
and segment parameters. It also allows you to monitor and measure specific 
system, segment and field device values. The continuous live monitoring of all 
relevant physical layer parameters enables the constant validation of the signal 
quality. This way degradations can be proactively detected before the segment 
communication fails.  
The Diagnostic Module is part of the diagnostic system, which consists of 
different hardware and software components that act as a whole. 
With the FDT/DTM based Diagnostic Manager the Diagnostic Module provides 
analysis of signal and segment parameters as well as measurement of specific 
system and field device physical layer values. The integrated powerful 
oscilloscope function visualizes the current communication at each segment. 
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Copyright and Trademark Notices 
￭ CENTUM and PRM are registered trademarks of YOKOGAWA. 

￭ FieldConnex® is a registered trademark of Pepperl+Fuchs. 

￭ Microsoft®, Windows® and Windows® XP are either registered trademarks 
or trademarks of Microsoft® Corporation in the United States and/or other 
countries. 

￭ Ethernet is a registered trademark of XEROX Corporation. 

￭  “FOUNDATION” in “FOUNDATION Fieldbus” is a registered trademark of 
Fieldbus Foundation. 

￭ All other company and product names mentioned in this manual are 
trademarks or registered trade-marks of their respective companies. 
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2. System Environment and 
Infrastructure 

The diagnostic infrastructure consists the following hardware and software 
components:   
￭ Diagnostic Modules 

￭ Yokogawa ALF111 Fieldbus Communication Module  

￭ PRM 

￭ FieldConnex® Diagnostic Server (FDS) 

￭ Diagnostic Manager 

Figure 1 provides an overview of all included components and how they inter-
connect. 
Each Advanced Diagnostic Module monitors up to 4 segments. The diagnostic 
communication is independent from the fieldbus communication and takes place 
via a separate 2-line wire using an RS 485 protocol, called the Diagnostic Bus 
(see also Figure 1). The Diagnostic Bus connects up to 31 ADM modules at a 
length of max. 30 meters. A Diagnostic Gateway installed within the field cabinet 
transmits the RS-485 Diagnostic Bus information to the FieldConnex® 
Diagnostic Server (FDS) using standard Ethernet topology. 
The FieldConnex® Diagnostic Server (FDS) installed on a PC provides access to 
the ADM diagnostic information straight through a Diagnostic Manager tool (DTM 
tool). Also, the FDS supports OPC-AE and OPC-DA services, thus, PRM Status 
and Message acquisition services are fed with alarm and maintenance 
information of all configured Advanced Diagnostic Modules. The FDS provides 
up to 255 FDS ports and handles 1 000 ADM devices and overall 4 000 
FOUNDATION FieldbusFieldbus segments. 
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Figure 1: Overview of the system environment 
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2.1.1 Segment Hierarchy and ADM Representation in 
PRM 
Each fieldbus segment monitored by the Advanced Diagnostic Module contains a 
“virtual” device. Figure 2 shows that the segments monitored by the Advanced 
Diagnostic Module are represented by devices within the PRM Network view. 

 

Figure 2 

During the engineering procedure a mapping takes place to establish a 
relationship between the Advanced Diagnostic Module and the appropriate PRM 
instance. 
By default, the following mapping is applied: 
￭ Each Slot/AKF111 has assigned one HD2-DM-A device which monitors up to 

4 channels of the slot. 

￭ All Slots/ALF111 of one node are mapped to one port inside the FDS DTM 
(see chapter 7). 

For mapping details refer to chapter 7. 
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3. System Requirements 
3.1 PC System Requirements 

Personal computer for PRM and FieldConnex® Diagnostic Server (FDS) 
￭ Operating systems: 

 Windows® Vista SP2 (32-bit) 

 Windows® 7 SP1 (64-bit) 

 Windows® Server 2008 SP2 (32-bit) 

 Windows® Server 2008 R2 SP1 (64-bit) 

￭ 3 GB RAM for PRM, 100 MB RAM for FDS, 100 MB RAM for Diagnostic 
Manager (DTM) 

3.2 Hardware Requirements 
Hardware Required 

Component Description 
HD2-DM-A Advanced Diagnostic Module plugged onto the 

Fieldbus Power Hub motherboard. 
Diagnostic Gateway Device that provides serial Ethernet to RS-485 

connectivity. 
VP or CS 3000 Distributed Control System 

3.3 Software Requirements 
Software Required 

Program Description 
FDS 2.2.0.2465 or 
later 

FieldConnex® Diagnostic Server is an interface and a 
data access coordinator for the HD2-DM-A, includes 
the OPC-AE service. 

Diagnostic Manager 
DTM 2.2.0.2465 or 
later  

Device Type Manager that represents the FDS, ports 
and connected HD2-DM-A modules. 
A DTM is the device's configuration and management 
software. It contains the graphic user dialogs and 
undertakes device configuration and diagnosis. The 
DTM can be launched straight out of the PRM. 

PRM R3.20 or later Plant Resource Manager 
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4. Engineering 
This chapter describes the software engineering procedures to integrate the 
Pepperl+Fuchs Advanced Diagnostic Module (ADM) into Yokogawa PRM. 
In addition, the necessary hardware and software configuration settings, as part 
of the engineering procedures, are described. 

4.1 System Topology Description 
Depending on the size and complexity of the plant, many different installation 
topologies are possible in practice. Thus, the hardware requirements depend on 
the given topology. For that reason, many different software installation 
workflows are possible. 
To simplify the engineering, this publication describes the three most common 
installation topologies and the corresponding work steps (WS) for proper 
installation of all components. The required software components are the same 
for all described topologies, but the hardware and where to install these 
components differs. 
Figure 3 shows a stylized comparison about the three most common installation 
topologies: 
A. All Components on the same PC 
B. PRM Client, Field Communication Server and PRM/FDS-Server 
C. PRM Client, Field Communication Server, PRM-Server and separate 

FDS-Server 

 

Figure 3: Installation topology comparison 
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Following the engineering procedure for each installation topology is described in 
detail. 

4.1.1 Installation Topology A: All Components on the 
Same PC 
All system components are installed on the same PC.  
In this case, you have to perform a complete PRM HD2-DM-A setup on this PC. 
For detailed engineering work steps (WS) see chapter 4.4.  

Components on hardware FieldConnex® Diagnostic Manager Setup 
installation profile 

 

 

 
 

Legend: 

 

PC workstation / PC server machine 

PRMc Plant Resource Manager Client Software 
PRMs Plant Resource Manager Server Software 
PRM-FCS Plant Resource Manager Field Communication Server 
FDS FieldConnex® Diagnostic Server 
DTM Diagnostic Manager 

 

4.1.2 Installation Topology B: PRM Client and PRM/FDS 
Server 
The PRM clients are installed on separate PCs, the PRM server and the FDS are 
installed on the same server machine. 
In this case, you are required to perform both the following: 
￭ PRM client setup on each PRM client PC with the Diagnostic Manager  

￭ Server setup on the server machine with the FieldConnex® Diagnostic 
Server 

For detailed engineering work steps (WS) see chapter 4.5. 
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Components on hardware FieldConnex® Diagnostic Manager Setup 
installation profile 

 
 

 

Install these components on each PC and on the server 
running PRM-FCS (Field Communication Server): 

  
Install these components on the server running 
PRMs/FDS: 

 
 

 

Legend: 

 

PC workstation 

 

Server machine 

PRM-FCS Plant Resource Manager Field Communication Server 
PRMc Plant Resource Manager Client Software 
PRMs Plant Resource Manager Server Software 
FDS FieldConnex® Diagnostic Server 
DTM Diagnostic Manager 
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4.1.3 Installation Topology C: PRM Client, PRM Server 
and Separate FDS Server 
All components are installed on different work stations and server machines. 
In this case, you are required to perform the following: 
￭ PRM client setup on each PRM client PC with the Diagnostic Manager 

￭ Server setup  on the PRM server machine and on the FDS server machine 
with the FieldConnex® Diagnostic Server  

For detailed engineering work steps (WS) see chapter 4.6. 
 

Components on hardware FieldConnex® Diagnostic Manager Setup 
installation profile 

 

Install these components on each PC running PRM-FCS 
(Field Communication Server): 

Install these components on the PRM server, Field 
Communication Server and the FDS server: 

 
 

Legend: 

 

PC workstation 

 

Server machine 

PRM-FCS Plant Resource Manager Field Communication Server 
PRMc Plant Resource Manager Client Software 
PRMs Plant Resource Manager Server Software 
FDS FieldConnex® Diagnostic Server 
DTM Diagnostic Manager 
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4.2 Required Software for Engineering 
Advanced Diagnostic Manager DTM 2.2.0.2465 or later 
COM port converter driver (depends on the used device) 
FieldConnex® Diagnostic Server (FDS) with OPC AE support 2.2.0.2465 or later 
Plant Resource Manager (PRM) R3.20 or later 
￭ PRM Setup Tool 

￭ PRM Hierarchy Import Tool 

￭ PRM Integration Wizard 

￭ PRM 

4.3 Work Step (WS) Overview 
To integrate the Advanced Physical Layer Diagnostics into the PRM 
environment, several work steps (WS) are necessary. These work steps do not 
depend on the kind of installation topology. 
The following table gives an overview about the work steps with the expected 
duration. The work steps must be performed in the correct order. 
Preconditions: 
The PRM and all Yokogawa-specific system components must be installed 
correctly. The plant hierarchy must be configured and the appropriate device 
path configuration definition file must be available and be imported into PRM. 
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S Task Tool 
1 Installation of the Pepperl+Fuchs 

Software 
Diagnostic Manager 
Setup, 
FDS Control Center 

2 PRM setup for integration of third-party 
condition monitoring for connection to 
FDS 

PRM Integration 
Wizard 

3 Generation of FDT project including 
ADM. 
Generation of Pepperl+Fuchs FDS-
Project including project 
documentation and PRM integration 
data needed to perform the work steps 
(WS) 4, 5, 6, and 7. 

￭ PRM Setup Tool 
￭ Yokogawa FDT 

Project Management 
Tool (DTMWorks) 

￭ Pepperl+Fuchs FDS-
DTM 

￭ Pepperl+Fuchs ADM-
DTM 

4 Import of PRM-specific mimosa file into 
PRM to generate Plant View and 
Network View hierarchies 

PRM Hierarchy 
Import Tool 

5 Address assignment of the Advanced 
Diagnostic Module hardware 

n.a. 

(6) (COM Converter driver installation 
(only required when COM converters 
are used instead of Diagnostic 
Gateways)) 

(COM Converter 
Driver Software) 

7 Add ADM Icons to PRM PRM 
8 Commissioning FOUNDATION 

Fieldbus. Baseline measurements of 
the physical layer parameters to define 
limits for online diagnostics. (max. 12 
devices per segment) 

Diagnostic Manager 

 

4.4 Installation Topology A: Detailed Work Step 
(WS) Description 

Below you find all work steps (WS) required to proceed if all components are 
installed on the same PC. 

WS 1 Pepperl+Fuchs Software Installation 
A. Install all appropriate software. Download the FieldConnex® Diagnostic Manager 

from www.pepperl-fuchs.com and proceed as follows to install the tool: 
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B. Choose “FieldConnexDiagnosticSetup.exe”. 

C. Accept License. 

D. Choose installation profile “Yokogawa PRM Integration – Single Machine”. 

E. Press [Next] and proceed with the installation wizard until the installation is 
complete. 

F. Start License Activation Tool from start menu ([Start] > [Pepperl+Fuchs] > 
[Activation Tool]). 

G. Enter a valid license key for HD2-DM-A and press [Activate]. 

H. Press [Finish] to close License Activation Tool. 

Start FDS Control Center from task bar (double-click  icon) or start menu (click 
[Start] > [Pepperl+Fuchs] > [FDS Control Center]). 
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I. Press [Settings…] button in toolbar of FDS Control Center to open settings 
window. 

  
J. Make sure that the option [Start with Windows®] is set as “Startup type”. 

K. Set “Adjust firewall to allow remote access” option. 

L. Press [OK] to close settings dialog. 

M. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

N. Skip the intro page and on the next page, select “PRM_PROCESS” from the user 
combo box. 

 
O. Uncheck “Allow Anonymous access” and “Execute FDS under the selected 

account” check box. 
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P. Finish the Wizard. Do NOT restart Windows® since the wizard has to be executed 
a second time. 

Q. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

R. Skip the intro page and on the next page, select an account for DCOM 
communication. This account must be a member of the Administrators group. 

 
S. Uncheck “Allow Anonymous access” check box. 

T. Activate “Execute FDS under the selected account” check box. 

U. On the next page, enter the password for the selected account. 

V. Finish the wizard and restart Windows® to apply settings. 
For further information refer to the HD2-DM-A manual. You can download the 
manual at www.pepperl-fuchs.com. 

WS 2 
 

PRM Setup for Integration of Third-Party Condition Monitoring 
for Connection to FDS 
This work step (WS) defines the OPC interface information required to pass ADM 
diagnostic messages to PRM Operator Guidance Messages and PRM Action 
Guidance Messages. 

A. Start the Integration Wizard (by default 
“C:\PRM\Tool\IntegrationWizard\PrmIntegrationWizard.exe”). 
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B. Skip the first page(s) up to page “New Instance”. 

 
C. In the Third-Party System drop-down list, choose [Pepperl+Fuchs FieldConnex® 

Advanced Diagnostic]. 

D. In the Instance Name box, enter the term “FDS”, then press [Next]. 

E. On “DCOM Authentication” page, enter the same account data as entered in “OPC 
Remote Access Wizard” before (WS 1, N.-R.) and press [Next]. 
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F. On “Message and Data Acquisition” page enter “localhost” into fields “Message 
Acquisition Server” and “Data Acquisition Server”. 

 
G. Press [Test Connection] to validate the connection. 

 
H. Press [Next]. 

I. Page “Operator Guide Template” appears. Press [Next]. 

J. Page “Integration Summary” appears. Press [Finish] and on final page [Close]. 

K. “PRM Server service” restart dialog appears. Press [Yes] to restart “PRM Server 
service”. 
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WS 3 
 

Generation of FDT Project, Pepperl+Fuchs FDS-Project and 
PRM Integration Data 

A. Make sure that the file DevicePath.txt is available. 

B. Start PRM Setup Tool by selecting [Start] > [PRM Tools] > [PRM Setup Tool]. 

C. Open the node [Field Communication] > [FDT Project Management (P+F ADM)] . 

 
D. Press the tool button [New] and assign a project name.  

↳ The FDT project management tool "DTM Works" opens.  

E. Update the DTM catalog in DTM Works by selecting [View] > [DTM Catalog] from 
the menu. In the "DTM Catalog" window, press "Update" and answer the 
subsequent request with "Yes".  

F. Right-click the root node in the "FDT Topology" window and select "Add" from 
context menu.  

G. Add the "FieldConnex Diagnostic Server (PRM)" DTM.  

H. Right-click on the new DTM ("FieldConnex Diagnostic Server (PRM)") in the "FDT 
Topology" window and select "Add" from the context menu.  

I. Add the "HD2-DM-A" DTM.  
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J. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 

K. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

L. Press button [Read Device Path File]. Browse to your project folder and choose 
the Device Path File. 

M. Confirm “Merge Result” dialog with [OK] to continue. 
 

N. Choose segments to be monitored with ADM. 

 
O. Press [Ok] to continue. 

P. Back on tab [FDS Topology Settings] go to the tree “Proposed ADM topology”, 
right-click on the first “Port” node and select “Change Address” from the appearing 
popup menu. 
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Q. Enter the IP of the Diagnostic Gateway that the assigned ADMs are connected to. 
(For details also see chapter 7). 

 
R. Press [OK] and assign Diagnostic Gateways to all other Ports of the project, too. 

S. Press [Apply]. 

T. Right-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

U. Press [Set topology] button in toolbar. 

V. Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 

↳ Three files are created in the output folder: 
ADM_devices_mimosa.xml > Contains all device and path information for the 
PRM integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

W. Open [File] menu and press [Save Project]. 

X. Close “DTM Works” and “PRM Setup Tool”. 
 

WS 4 Importing Project Structure into PRM 
The Yokogawa “PRM Hierarchy Import Tool” imports Plant View and Network 
View hierarchy definitions and devices for FOUNDATION Fieldbus segments. 
These definitions and devices were created by the Pepperl+Fuchs FDS for the 
PRM DTM in the previous WS 3. 

A. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

B. Press [Open PRM Hierarchy]. Log-in dialog appears. 

C. Enter log-in data and confirm with [OK]. 

D. Press [Open Import file]. 
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E. In the drop-down list, choose FDS and confirm with [OK]. 

F. Choose file “ADM_devices_mimosa.xml” from the export folder you created earlier 
and press [Open]. 

G. Drag and drop the node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure you create this 
structure project-specifically first. 

 
H. In the appearing dialog “Merge Hierarchy Info”, check that the segments are 

marked with type “CONTROL MODULE” within the “Type Selection” column. 

 
I. Confirm with [OK]. 

J. Press [Upload to database] button ( ) in toolbar. 

K. Close “Hierarchy Import Tool”. 
 

WS 5 
 

Address Assignment of the Advanced Diagnostic Module 
Hardware 
Place the eight switches of the DIP switch at the left module side in the correct 
position to generate the required address. For address scheme, see label on the 
module (for further information see also HD2-DM-A manual). 

This work step (WS) has to be performed for each module. The appropriate 
address for each module can be found on the report created in WS 3. 

Make sure that the ADMs are connected to the Diagnostic Gateway with the 
IP address specified in WS 3. This information, too, can be found in the report 
created in WS 3. 
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WS 6 COM Converter Driver Installation 
If Diagnostic Gateways are used for connection between ADM devices and FDS 
PC, continue with WS 7. 

If using a COM port converter instead of Diagnostic Gateways, proceed as 
follows: Install the drivers delivered with the COM port converter and adjust the 
COM ports to match the settings set in WS 3. For details also see chapter 7. 

WS 7 Add ADM Icons to PRM 
A. Start PRM by selecting [Start] > [PRM] > [Plant Resource Manager] and log in. The 

currently imported hierarchy appears. 

B. Choose [Register] > [Master Data] > [Register Device Icon…]. 

 
C. Press button [Add…]. 

D. Choose image “ADMBitmap.bmp” from the export folder created in WS 3. 

E. Confirm with [OK] and close “Device Icon List” dialog. 

F. Choose [Register] > [Master Data] > [Assign Icon]. 

G. Press button [Add…] and make the following settings: 

 
H. Confirm with [OK] and close “Assignment of Device Icons” dialog. 
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WS 8 
 

Automatic FOUNDATION Fieldbus Segment Diagnostic 
Commissioning 
Match the limits of the monitored physical layer parameters to a specific physical 
segment within the PRM. To do so, launch an automatic scan and setup 
procedure for each physical FOUNDATION Fieldbus segment. 

The Pepperl+Fuchs Diagnostic Manager provides a special function for 
commissioning issues, the so called commissioning wizard. 

This is a comfortable tool for fast and easy start-up with the Diagnostic Module. 
The wizard leads you step-by-step through a complete system and segment 
analysis to ensure that a segment is healthy to go online. Afterwards, the PRM 
database is automatically updated with the baseline settings generated by the 
commissioning wizard. 

 

4.5 Installation Topology B: Detailed Work Step 
(WS) Description 

WS 1.1 Pepperl+Fuchs Software Installation 
Download the Pepperl+Fuchs tools from www.pepperl-fuchs.com. In order to 
install the software, proceed as follows. 

Client installation. Install the client on each client PC and on Field Communication 
Server. 

 
Tip 

 PRM Client Software 
Ensure you install the PRM Client software on each client PC. 

 

A. Choose “FieldConnexDiagnosticSetup.exe.” 

B. Accept License. 

C. Choose the installation profile “Yokogawa PRM Integration – Client”. 
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D. Press [Next] and proceed with the installation wizard until installation is complete. 

E. Start License Activation Tool from start menu ([Start] > [Pepperl+Fuchs] > 
[Activation Tool]). 

F. Enter a valid license key for HD2-DM-A and press [Activate]. 

G. Press [Finish] to close License Activation Tool. 
 

WS 1.2 PRM Server/FDS Server Installation 

 
Tip 

 PRM Server Software 
Install PRM server software first. 

A. Choose “FieldConnexDiagnosticSetup.exe.” 

B. Accept License. 

C. Choose the installation profile “Yokogawa PRM Integration – Server”. 

 
D. Press [Next] and proceed with the installation wizard until installation is complete. 
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E. Start FDS Control Center from task bar (double-click  icon) or start menu (click 
[Start] > [Pepperl+Fuchs] > [FDS Control Center]). 

 
F. Keep the IP address listed under “IP Addresses” in mind. You will need it in WS 3. 

G. Press [Settings…] button in toolbar of FDS Control Center to open settings 
window. 

 
H. Make sure that the option [Start with Windows®] is set as “Startup type”. 

I. Set “Adjust firewall to allow remote access” option. 
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J. Press [OK] to close settings dialog. 

K. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

L. Skip the intro page and on the next page, select “PRM_PROCESS” from the user 
combo box. 

 
M. Uncheck “Allow Anonymous access” and “Execute FDS under the selected 

account” check box. 

N. Finish the wizard. Do NOT restart Windows® since the wizard has to be executed 
a second time. 

O. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

P. Skip the intro page and on the next page, select an account for DCOM 
communication. This account must be a member of the Administrators group. 

 
Q. Uncheck “Allow Anonymous access” check box. 

R. Activate “Execute FDS under the selected account” check box. 



FIELDBUS SEGMENT DIAGNOSTICS WITH THE ADM | ENGINEERING 

31 

S. On the next page, enter the password for the selected account. 

T. Finish the wizard and restart Windows® to apply the settings. 
 

For further information please refer to the HD2-DM-A manual. The manual can be 
downloaded at www.pepperl-fuchs.com. 

 

WS 2 
 

PRM Setup for Integration of Third-Party Condition Monitoring 
for Connection to FDS 
This work step (WS) defines the OPC interface information which is needed to 
pass ADM diagnostic messages to PRM Operator Guidance Messages and PRM 
Action Guidance Messages. The following actions have to be executed on the 
PRM/FDS server. 

A. Start the Integration Wizard (by default 
“C:\PRM\Tool\IntegrationWizard\PrmIntegrationWizard.exe”). 

B. Skip the first page(s) up to page “New Instance”. 

 
C. In the Third-Party System drop-down list, choose [Pepperl+Fuchs FieldConnex® 

Advanced Diagnostic]. 

D. In the Instance Name box, enter the term “FDS”, then press [Next]. 
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E. On “DCOM Authentication” page, enter the same account data as entered in “OPC 
Remote Access Wizard” before (WS 1.2, L.-P.) and press [Next]. 

 
F. On “Message and Data Acquisition” page enter “localhost” into the fields “Message 

Acquisition Server” and “Data Acquisition Server”. 

 
G. Press [Test Connection] to validate the connection. 

 
H. Press [Next]. 

I. Page “Operator Guide Template” appears. Press [Next]. 

J. Page “Integration Summary” appears. Press [Finish] and on final page [Close]. 

K. “PRM Server service” restart dialog appears. Press [Yes] to restart “PRM Server 
service”. 
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WS 3 
 

Generation of FDT Project, Pepperl+Fuchs FDS-Project and 
PRM Integration Data 
The following actions have to be executed on the PRM/FDS server. 

A. Make sure that the file DevicePath.txt is available. 

B. Start PRM Setup Tool by selecting [Start] > [PRM Tools] > [PRM Setup Tool]. 

C. Open the node [Field Communication] > [FDT Project Management (P+F ADM)]. 

 
D. Press the tool button [New] and assign a project name.  

↳ The FDT project management tool "DTM Works" opens.  

E. Update the DTM catalog in DTM Works by selecting [View] > [DTM Catalog] from 
the menu. In the "DTM Catalog" window, press "Update" and answer the 
subsequent request with "Yes". 

F. Right-click the root node in the "FDT Topology" window and select "Add" from 
context menu. 

G. Add the "FieldConnex Diagnostic Server (PRM)" DTM. 

H. Right-click on the new DTM ("FieldConnex Diagnostic Server (PRM)") in the "FDT 
Topology" window and select "Add" from the context menu. 

 

I. Add the "HD2-DM-A" DTM. 
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J. Double-click on the node FieldConnex® Diagnostic Server (PRM) in FDT 
Topology window. 

K. The Offline parameterization window appears. Choose tab [FDS Parameters]. 

L. Change “FDS Location” to “Remote” and enter the IP address of the PRMs/FDS 
PC in field “Remote IP Address”. The IP address is the same address as seen in 
FDS Control Center at WS 1.2, F. 

 
M. Choose tab [FDS Topology Settings]. 

N. Press button [Read Device Path File]. Browse to your project folder and choose 
the Device Path File. 

O. Confirm “Merge Result” dialog with [OK] to continue. 

P. Choose segments to be monitored with ADM. 

 
Q. Press [Ok] to continue. 
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R. Back on tab [FDS Topology Settings] go to the tree “Proposed ADM topology”, 
right-click on the first “Port” node and select “Change Address” from the appearing 
popup menu. 

 
S. Enter the IP address of the Diagnostic Gateway the assigned ADMs are connected 

to. (For details also see chapter 7). 

 
T. Press [OK] and assign Diagnostic Gateways to all other ports of the project, too. 

U. Press [Apply]. 

V. Right-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

W. Press [Set topology] button in toolbar. 

X. Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 

↳ Three files are created in the output folder: 
ADM_devices_mimosa.xml > Contains all device and path information for the 
PRM integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

Y. Open [File] menu and press [Save Project]. 

Z. Close “DTM Works” and “PRM Setup Tool”. 
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WS 4 Importing Project Structure into PRM 
The Yokogawa “PRM Hierarchy Import Tool” imports Plant View and Network 
View hierarchy definitions and devices for FOUNDATION Fieldbus segments. 
These definitions and devices were created by the Pepperl+Fuchs FDS for the 
PRM DTM in the previous WS 3. The following actions have to be executed on 
the PRM/FDS Server. 

A. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

B. Press [Open PRM Hierarchy]. The log-in dialog appears. 

C. Enter log-in data and confirm with [OK]. 

D. Press [Open Import file]. 

E. In the drop-down list, choose FDS and confirm with [OK]. 

F. Choose file “ADM_devices_mimosa.xml” from the export folder you created earlier 
and press [Open]. 

G. Drag and drop the node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure you create this 
structure project-specifically first. 

 
H. In appearing dialog “Merge Hierarchy Info”, check that the segments are marked 

with type “CONTROL MODULE” within the “Type Selection” column. 

 
I. Confirm with [OK]. 

J. Press [Upload to database] button ( ) in toolbar. 

K. Close “Hierarchy Import Tool”. 
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WS 5 
 

Address Assignment of the Advanced Diagnostic Module 
Hardware 
Place the eight switches of the DIP switch at the left module side in the correct 
position to generate the required address. For address scheme, see label on the 
module. For further information see also the HD2-DM-A manual. 

This work step (WS) has to be performed for each module. The appropriate 
address for each module can be found on the report created in WS 3. 

Make sure that the ADMs are connected to the Diagnostic Gateway with the 
IP address specified in WS 3. This information, too, can be found in the report 
created in WS 3. 

 

WS 6 COM Converter Driver Installation 
If Diagnostic Gateways are used for the connection between ADM devices and 
the FDS PC, continue with WS 7. 

If using a COM port converter instead of Diagnostic Gateways, proceed as 
follows: install the drivers delivered with the COM port converter and adjust the 
COM ports to match the settings set in WS 3. For details also see chapter 7. 

 

WS 7 Add ADM Icons to PRM 
A. Start PRM by selecting [Start] > [PRM] > [Plant Resource Manager] and log in. The 

currently imported hierarchy appears. 

B. Choose [Register] > [Master Data] > [Register Device Icon]. 

 
C. Press button [Add…]. 

D. Choose image “ADMBitmap.bmp” from the export folder created in WS 3. 

E. Confirm with [OK] and close “Device Icon List” dialog. 

F. Choose [Register] > [Master Data] > [Assign Icon]. 
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G. Press button [Add…] and make the following settings: 

 
H. Confirm with [OK] and close “Assignment of Device Icons” dialog. 

 

WS 8 
 

Automatic FOUNDATION Fieldbus Segment Diagnostic 
Commissioning 
Match the limits of the monitored physical layer parameters to a specific physical 
segment within the PRM. To do so, launch an automatic scan and setup 
procedure for each physical FOUNDATION Fieldbus segment. 

The Pepperl+Fuchs Diagnostic Manager provides a special function for 
commissioning issues, the so called commissioning wizard. 

This is a comfortable tool for fast and easy start-up with the Diagnostic Module. 
The wizard leads you step-by-step through a complete system and segment 
analysis to ensure that segment is healthy to go online. Afterwards, the PRM 
database is automatically updated with the baseline settings generated by the 
commissioning wizard. 

 

4.6 Installation Topology C: Detailed Work Step 
(WS) Description 

WS 1.1 Pepperl+Fuchs Software Installation 
Download the Pepperl+Fuchs tools from www.pepperl-fuchs.com. In order to 
install the tools, proceed as follows. 

Make sure that the same local user account with the same password is installed 
on the PC/Server machine of the PRM Server and of the FDS. 

Client installation: Repeat WS 1.1 on each client PC and on Field Communication 
Server. 
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Tip 

 PRM Client Software 
Ensure you install the PRM Client software on each client PC. 

A. Choose “FieldConnexDiagnosticSetup.exe.” 

B. Accept License. 

C. Choose the installation profile “Yokogawa PRM Integration – Client”. 

 
D. Press [Next] and proceed with the installation wizard until installation is complete. 

E. Start License Activation Tool from start menu ([Start] > [Pepperl+Fuchs] > 
[Activation Tool]). 

F. Enter a valid license key for HD2-DM-A and press [Activate]. 

G. Press [Finish] to close License Activation Tool. 
 

WS 1.2 Server Installation PRM 

 
Tip 

 PRM Server Software 
Install PRM server software. 
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WS 1.3 Server Installation FDS 
A. Choose “FieldConnexDiagnosticSetup.exe” from folder “FieldConnex® Diagnostic 

Manager.” 

B. Accept License. 

C. Choose the installation profile “Yokogawa PRM Integration – Server”. 

 
D. Press [Next] and proceed with the installation wizard until installation is complete. 

E. Start FDS Control Center from task bar (double-click  icon) or start menu (click 
[Start] > [Pepperl+Fuchs] > [FDS Control Center]). 

 
F. Keep the host name and IP address (of the FDS PC) at hand for WS 2 and WS 3. 
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G. Press [Settings…] button in toolbar of FDS Control Center to open settings 
window. 

 
H. Make sure that the option [Start with Windows®] is set as “Startup type”. 

I. Set “Adjust firewall to allow remote access” option. 

J. Press [OK] to close settings dialog. 

K. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

L. Skip the intro page and on the next page, select “PRM_PROCESS” from the user 
combo box. 

 
M. Uncheck “Allow Anonymous access” and “Execute FDS under the selected 

account” check box. 
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N. Finish the wizard. Do NOT restart Windows® since the wizard has to be executed 
a second time. 

O. Choose [Tools] from the toolbar and select [OPC Remote Access…] in popup 
menu. 

P. Skip the intro page and on the next page, select an account for DCOM 
communication. This account must be a member of the Administrators group. 
Remember: An account with the same user name and password is required on the 
PRM server PC. 

 
Q. Uncheck “Allow Anonymous access” check box. 

R. Activate “Execute FDS under the selected account” check box. 

S. On the next page, enter the password for the selected account. 

T. Finish the wizard and restart Windows® to apply the settings. 
 

For further information, refer to the HD2-DM-A manual. The manual can be 
downloaded at www.pepperl-fuchs.com. 

 

WS 2 
 

PRM Setup for Integration of Third-Party Condition Monitoring 
for Connection to FDS 
This work step (WS) defines the OPC interface information required to pass ADM 
diagnostic messages to PRM Operator Guidance Messages and PRM Action 
Guidance Messages. 

Carry out the following actions on the machine on which the PRM server is 
installed on. 

A. Start the Integration Wizard (by default 
“C:\PRM\Tool\IntegrationWizard\PrmIntegrationWizard.exe”). 
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B. Skip the first page(s) up to page “New Instance”. 

 
C. In the Third-Party System drop-down list, choose [Pepperl+Fuchs FieldConnex® 

Advanced Diagnostic]. 

D. In the Instance Name box, enter the term “FDS”, then press [Next]. 

E. On “DCOM Authentication” page, enter the same account data as entered in “OPC 
Remote Access Wizard” before (WS 1.3, L.-P.) and press [Next]. 
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F. On “Message and Data Acquisition” page enter the host name or IP address of 
FDS PC into fields “Message Acquisition Server” and “Data Acquisition Server”. 
To resolve host name and IP address open the FDS Control Center on FDS PC 
(see WS 1.3, F.). 

 
G. Press [Test Connection] to validate the connection. 

 
H. Press [Next]. 

↳ Page “Operator Guide Template” appears.  

I. Press [Next]. 

↳ Page “Integration Summary” appears.  

J. Press [Finish] and on final page [Close]. 

↳ “PRM Server service” restart dialog appears.  

K. Press [Yes] to restart “PRM Server service”. 
 

WS 3 
 

Generation of FDT Project, Pepperl+Fuchs FDS-Project and 
PRM Integration Data 
The following actions have to be executed on the Field Communication Server. 

A. Make sure that the file DevicePath.txt is available. 

B. Start PRM Setup Tool by selecting [Start] > [PRM Tools] > [PRM Setup Tool]. 
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C. Open the node [Field Communication] > [FDT Project Management (P+F ADM)]. 
 

 
D. Press the tool button [New] and assign a project name.  

↳ The FDT project management tool "DTM Works" opens. 

E. Update the DTM catalog in DTM Works by selecting [View] > [DTM Catalog] from 
the menu. In the "DTM Catalog" window, press "Update" and answer the 
subsequent request with "Yes". 

F. Right-click the root node in the "FDT Topology" window and select "Add" from 
context menu. 

G. Add the "FieldConnex Diagnostic Server (PRM)" DTM. 

H. Right-click on the new DTM ("FieldConnex Diagnostic Server (PRM)") in the "FDT 
Topology" window and select "Add" from the context menu. 

I. Add the "HD2-DM-A" DTM. 

 
J. Double-click on the node FieldConnex® Diagnostic Server (PRM) in the FDT 

Topology window. 

K. The Offline parameterization window appears. Choose tab [FDS Parameters]. 

L. Change “FDS Location” to “Remote” and enter the IP address of the PRMs/FDS 
PC in field “Remote IP Address”. The IP address is the same address as seen in 
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the FDS Control Center in WS 1.3, F. 

 
M. Choose tab [FDS Topology Settings]. 

N. Press the button [Read Device Path File]. Browse to your project folder and 
choose the Device Path File. 

O. Confirm “Merge Result” dialog with [OK] to continue. 

P. Choose segments to be monitored with ADM. 

 
Q. Press [Ok] to continue. 

R. Back on tab [FDS Topology Settings] go to the tree “Proposed ADM topology”, 
right-click on the first “Port” node and select “Change Address” from the appearing 
popup menu. 
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S. Enter the IP of the Diagnostic Gateway the assigned ADMs are connected to. (For 
details also see chapter 7). 

 
T. Press [OK] and assign Diagnostic Gateways to all other Ports of the project, too. 

U. Press [Apply]. 

V. Right-click on the node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

W. Press [Set topology] button in toolbar. 

X. Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 

↳ Three files are created in the output folder 
ADM_devices_mimosa.xml > Contains all device and path information for the 
PRM integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

Y. Open [File] menu and press [Save Project...]. 

Z. Close “DTM Works” and “PRM Setup Tool”. 
 

WS 4 Importing Project Structure into PRM 
The Yokogawa “PRM Hierarchy Import Tool” imports Plant View and Network 
View hierarchy definitions and devices for FOUNDATION Fieldbus segments. 
These definitions and devices were created by the Pepperl+Fuchs FDS for PRM 
DTM in WS 3. The following actions have to be executed on the PRM server. 

A. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

B. Press [Open PRM Hierarchy]. Log-in dialog appears. 

C. Enter log-in data and confirm with [OK]. 

D. Press [Open Import file]. 

E. In the drop-down list, choose FDS and confirm with [OK]. 
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F. Choose file “ADM_devices_mimosa.xml” from the output folder you created earlier 
and press [Open]. 

G. Drag and drop the node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure to create this 
structure project-specifically first. 

 
H. In appearing dialog “Merge Hierarchy Info”, check that the segments are marked 

with type “CONTROL MODULE” within the “Type Selection” column. 

 
I. Confirm with [OK]. 

J. Press [Upload to database] button ( ) in toolbar. 

K. Close “Hierarchy Import Tool”. 

 
WS 5 
 

Address Assignment of the Advanced Diagnostic Module 
Hardware 
Place the eight switches of the DIP switch at the left module side in the correct 
position to generate the required address. For address scheme, see label on the 
module (for further information see also HD2-DM-A manual). 

This work step (WS) has to be performed for each module. The appropriate 
address for each module can be found on the report created in WS 3. 

Make sure that the ADMs are connected to the Diagnostic Gateway with the IP 
address specified in WS 3. This information, too, can be found in the report 
created in WS 3. 
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WS 6 COM Converter Driver Installation 
If Diagnostic Gateways are used for connection between ADM devices and the 
FDS PC, continue with WS 7. 

If using a COM port converter instead of Diagnostic Gateways, install the drivers 
delivered with the COM port converter next and adjust the COM ports to match 
the settings set in WS 3. (For details also see chapter 7). 

WS 7 Add ADM Icons to PRM 
A. Start PRM by selecting [Start] > [PRM] > [Plant Resource Manager] and log in. The 

currently imported hierarchy appears. 

B. Choose [Register] > [Master Data] > [Register Device Icon]. 

 
C. Press button [Add…]. 

D. Choose image “ADMBitmap.bmp” from the export folder created in WS 3. 

E. Confirm with [OK] and close “Device Icon List” dialog. 

F. Choose [Register] > [Master Data] > [Assign Icon]. 

G. Press button [Add…] and make the following settings: 

 
H. Confirm with [OK] and close “Assignment of Device Icons” dialog. 

  



FIELDBUS SEGMENT DIAGNOSTICS WITH THE ADM | ENGINEERING 

50 

 

WS 8 
 

Automatic FOUNDATION Fieldbus Segment Diagnostic 
Commissioning 
Match the limits of the monitored physical layer parameters to a specific physical 
segment within the PRM. To do so, launch an automatic scan and setup 
procedure for each physical FOUNDATION Fieldbus segment. 

The Pepperl+Fuchs Diagnostic Manager provides a special function for 
commissioning issues, the so called commissioning wizard. 

This is a comfortable tool for fast and easy start-up with the Diagnostic Module. 
The wizard leads you step-by-step through a complete system and segment 
analysis to ensure that segment is healthy to go online. Afterwards, the PRM 
database is automatically updated with the baseline settings generated by the 
commissioning wizard. 
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5. Operation 
5.1 Status, Maintenance and Alarm Messages 

The integration of the Pepperl+Fuchs Advanced Diagnostic Module into 
Yokogawa PRM system makes the behavior of the H1 physical layer transparent 
for the user. This way, operation and maintenance personnel can proactively 
schedule repair work before communications or plant failure occur. 
The Diagnostic Manager provides two different physical layer alarm categories: 
￭ Maintenance alarms 

￭ Out of specification alarms 

You can adjust the maintenance alarms. All maintenance alarm limits can be 
adapted to the specific requirements of each segment. For each physical layer 
value, minimum and maximum limits can be set and activated. If the value 
violates the limit, a maintenance alarm is released in the Diagnostic Manager and 
via the OPC interface in the operator application. With this proactive diagnosis, 
error sources can be found before communication fails. 
Out of specification alarm limit values are derived from the IEC 61158-2 standard. 
The alarm limit values can be switched on and off, but cannot be individually 
adjusted. If these limits are violated, there is an increased risk of communication 
failure. 

5.1.1 PRM Message Information 
To provide the best possible assistance for the user, the different statuses are 
shown with different colors. The table below gives an overview of these colors 
and the meaning of the message. 
The device status icon indicates the current health of a device. It appears as a 
status color icon next to registered devices in the network view. Each color 
represents a different status. 
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Icon Color Description 

 
 The exclamation mark shows that a maintenance alarm has occurred. This 

alarm has not been acknowledged. 

 
Green Good, no message or alarm. 

 
Blue Maintenance required: Maintenance required alarm exists for this segment 

 
Red Hardware rrror: HW error was detected for the HD2-DM-A monitoring this 

segment. 

 
Gray Communication error: A communication error was detected for the  

HD2-DM-A monitoring this segment. 

 
Yellow Out of specification: Out of specification alarm exists for this segment. 

 
White Pending: Occurs during start-up period when no diagnostic information is 

available. 
 

5.1.2 Diagnostic Manager Message Information 
Icon Color Description 

 Green Monitored value / segment healthy 

 Blue Maintenance alarm active 

 Yellow Monitored value / segment is out of specification 
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6. How to Use the ADM 
This section provides an overview of the workflow and the work steps required 
upon receiving a message. 
The general workflow is: 
￭ The message for the operator generated by the Advanced Diagnostic Module 

can be detected by CENTUM CAMS for HIS. Next, the operator can inform 
the maintenance personnel to look after the specific message / segment. 

￭ The maintenance personnel opens PRM to check and validate the message 
and the status: 

 Alarm or message is still active. The maintenance personnel selects the 
Diagnostic Manager on PRM Device navigator, then right-click > open 
DTM Works. The current segment where the message has occurred is 
directly shown and active for detailed analysis. 

 Alarm is not active anymore > acknowledge message. 

Figure 4 shows a stylized overview about involved personnel, software tools and 
activities. 

 

Figure 4: General workflow overview 
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Figure 5: Status Representation within PRM 

 

Figure 6: Message view within PRM 

 

Figure 7: Diagnostic Manager detailed view  
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7. Port Mapping and Packing 
7.1 Port Mapping 

During the engineering procedure a mapping takes place to establish a 
relationship between the Advanced Diagnostic Module and the appropriate PRM 
instance. 
By default, the following mapping is applied: 
￭ Each Slot/AKF111 has assigned one HD2-DM-A device which monitors up to 

4 channels of the slot. 

￭ All Slots/ALF111 of one node are mapped to one port inside the FDS DTM 
(see chapter 7). 

 

Figure 8 

Depending on the connection path used between FDS and the HD2-DM-A 
devices, the addressing differs. 
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7.1.1 Use the Diagnostic Gateway 
Using Pepperl+Fuchs Diagnostic Gateways is the recommended way to connect 
the HD2-DM-A devices to the PC the FDS is running on. 
Each Diagnostic Gateway is capable to connect up to 64 HD2-DM-A devices. 
Each Diagnostic Gateway is represented by a port inside FDS DTM. 
The Diagnostic Gateway is addressed by IP address only. To obtain the IP 
addresses of the installed devices, use the FDS DTM (see below) or the 
Diagnostic Gateway Configuration Tool (DGCT) from Diagnostic Manager 
Installation CD. 

Set the IP Address of a Port 
To set the IP address of a port, perform the following procedure: 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 

D. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 
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E. Right-click on “Port” node and select “Change Address” from the appearing popup 
menu. 

 
F. In the appearing window, select “Diagnostic Gateway” option and enter the IP 

address of the Diagnostic Gateway. 

 
G. If an existing project is changed, it may be necessary to perform additional steps to 

make this setting work (see chapter 8.2). 
 

If the IP addresses of the diagnostic gateways are not known yet, perform the 
following procedure: 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Right-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

D. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 
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E. The Offline-parameterization window appears. Choose tab [FDS Topology 
Settings]. 

F. Take a look at the lower right section “Scanned Diagnostic Gateways”. 

G. If the Diagnostic Gateways are located in the same subnet as the PRM PC 
currently running, proceed as follows: press [Update] to get a list of all available 
Diagnostic Gateways. 

 
If the Diagnostic Gateways are located in another subnet (e. g., behind a router), it 
is required that the IP address of one diagnostic gateway is known. Enter this IP 
address in the field “Remote subnet IP address” and press [Add]. Then press 
[Update] to get a list of all Diagnostic Gateways in this subnet. 

 
H. To assign a Diagnostic Gateway to a Port, click on the Diagnostic Gateway, drag it 

from the list and drop it on the required port. 

 
I. If an existing project is changed, it may be necessary to perform additional steps to 

make this setting work (see chapter 8.2). 
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7.1.2 Use COM Port Converters 
Using COM port converters to establish the physical connection between FDS 
PC and the HD2-DM-A devices is not supported anymore and only described for 
compatibility reasons. 

7.1.2.1 Install COM Port Converters 
COM port converters always consist of two parts: the physical Ethernet to 
RS-485 converter device and the driver software providing virtual COM ports to 
access the physical device. Each virtual COM port on the PC represents one 
physical COM port converter device. 
Perform the following actions to set up COM port converters: 

A. Use manufacturer’s installation CD of the COM port converter to install the 
appropriate driver on the PC the FDS/FDS Control Center is installed on. 

B. When the driver has been installed correctly, open the administration menu of the 
COM port converter driver. 

C. Adjust the project-specific COM port addresses. You find this information on the 
report created with FDS DTM using FieldMate. Usually, the COM port number start 
from COM20. 

 
D. Check if the setting RS-485 2-Wire is active. 

 

7.1.2.2 Set Up a Project Using COM Port Converters 
Inside FDS DTM, each COM converter is assigned to one FDS port. That means 
a virtual COM port has to be assigned to each FDS Port. The virtual COM ports 
normally start at COM20 and are enumerated in ascending order. 
To set up or change a COM port, perform the following actions: 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 
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D. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

E. Right-click on “Port” node and select “Change Address” from the appearing popup 
menu 

 
F. In the appearing window, select “Serial Port” option and select the required COM 

port in the combo box. 

 
G. If an existing project is changed, it may be necessary to perform additional steps to 

make this setting work (see chapter 8.2). 
 

7.2 Port Packing 
One Diagnostic Gateway (or COM port converter) connects all Advanced 
Diagnostic Modules on the same Diagnostic Bus to one FDS port. By default, 
there is a 1:1 relation between nodes and FDS ports. That means each node is 
mapped to one FDS port. Depending on the real plant topology, this behavior 
may be not ideal for every case. 
Therefore it is possible to change the mapping conventions of the FDS ports 
during the engineering process, to customize the topology to the given 
conditions. By using the packing function, it is possible to collect up to 8 nodes at 
one FDS port. 
It is possible to choose the mapping method during the engineering procedure 
within the “Merge Result” dialog of FDS DTM. By default, one node is mapped to 
one FDS port. 
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7.2.1 Packing = 1. Each node refers to one FDS port 
(default behavior) 
The figure below shows that each node is assigned to one FDS port. 

 

Figure 9 

7.2.2 Packing = 2. Two nodes refer to one FDS port 
The figure below shows the result. Nodes 01 and 02 are assigned to first port. 
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Figure 10 

7.2.3 Packing = 3. Three nodes refer to one FDS port 

 

Figure 11 
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7.2.4 Packing = 4/8. Four/Eight nodes refer to one FDS 
port 
The mapping always takes place in consecutive order. This means that the nodes 
are sorted by consecutive numbers. E. g., if the packing method “Four nodes per 
port” is selected, the nodes 1, 2, 3 and 4 are assigned to one port. The nodes 
5 ... 8 are assigned to the next port and so on. 

 
Example 

 The device FCS0101 contains node 1 to 3 with three devices each and node 5 with 
three devices as well. Node 4 is missing or does not contain FOUNDATION 
Fieldbus devices (see figure below left side). 
As a result of the mapping, the first 3 nodes are assigned to the first FDS port. 
Node 5 is, however, assigned to the next FDS port. 
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Note 

 Number of Diagnostic Modules 
Within common installations, only 31 Diagnostic Modules are allowed on one COM 
port. 
If four nodes with eight ALF 111 FF Communication Modules are used, 32 
Diagnostic Modules can be assigned to one COM port. In this special case, this 
assembly works well. 
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8. Changing Configurations 
The setup configuration assigned during engineering may be changed at any 
time of operation. If major changes within the plant topology happen, it may make 
sense to perform a complete engineering from the beginning. To change single 
settings, follow the instructions below. 

8.1 Add Segments 
Make sure that the new file DevicePath.txt is available. 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Right-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

D. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 

E. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

F. Press button [Read Device Path File]. Browse to your project folder and choose 
the Device Path File. Confirm message box with [Ok]. 

G. Choose segments to be monitored with ADM. 

 
H. Press [Ok] to continue. 

I. Adjust the address of the new segment(s). 

J. Press [Set topology] button in toolbar. 
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K. Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 

↳ Three files are created in the output folder: 
ADM_devices_mimosa.xml > Contains all device and path information for the 
PRM integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

L. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

M. Press [Open PRM Hierarchy]. Log-in dialog appears. 

N. Enter log-in data and confirm with [OK]. 

O. Press [Open Import file]. 

P. In the drop-down list, choose FDS and confirm with [OK]. 

Q. Choose file “ADM_devices_mimosa.xml” from the export folder you created earlier 
and press [Open]. 

R. Drag&Drop node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure to create this 
structure project-specifically first. 

 
S. In appearing dialog “Merge Hierarchy Info”, check that the segments are marked 

with type “CONTROL MODULE” within the “Type Selection” column. 
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T. Confirm with [OK]. 

U. Press [Upload to database] button ( ) in toolbar. 

V. Close “Hierarchy Import Tool”. 
 

8.2 Handling Port Address or ADM Address 
Configurations 
8.2.1 Overview of Possible Configuration Changes 

The following configurations can be done for the FDS: 

Rearrange Ports This function is for use with COM port converters only. Do 
not use it if Diagnostic Gateways are used. 
This function is changing all COM port addresses of the 
FDS ports beneath this FDS node. You can choose the 
starting COM port number of the first port. Everything that 
follows is numbered in ascending order. 

Add Port This function adds a port to this particular FDS node. 
(Requires new generation and afterwards import of the 
“ADM_devices_mimosa.xml” file within PRM Hierarchy 
Import Tool.) 

The following configurations can be done for the COM port: 

Change Address This function is changing the IP address or COM port 
address of this particular port. 

Change Tag This function is changing the tag of this particular port. 
(Requires new generation and afterwards import of the 
“ADM_devices_mimosa.xml” file within PRM Hierarchy 
Import Tool.) 

Rearrange HD2-
DM-As 

This function is changing all addresses of HD2-DM-A 
modules beneath this port. You can choose the starting 
address number for the first device. Everything that follows 
is numbered in ascending order. 

Delete This function removes the port with all connected HD2-
DM-A modules. 

The following configurations can be done for the HD2-DM-A module: 

Change Address This function is changing the address of this particular 
HD2-DM-A module. 
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8.2.2 Example of a Changing Procedure 
The following example shows you how to change the address of a HD2-DM-A 
module. For changes of port or FDS configurations you can proceed as shown, 
but you have to focus the appropriate FDS or port node. 

 
CAUTION! 

 Consider before using Rearrange functions! 
The Rearrange functions are causing major changes within the 
configuration. 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Right-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

D. Double-click on node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window. 

E. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

F. Right-click on the required “HD2-DM-A” node and select “Change Address” from 
the appearing popup menu. 

 
G. Choose new address and confirm with [OK]. 
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H. Press [Apply] and afterwards press [Set topology] in toolbar. 

I. Open [File] menu and press [Save FDT Project]. 
 

If you have added a port or changed a port tag, proceed with the following 
actions additionally: 

A. Continuation of action I. above:  
Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 
Three files are created at the output folder: 
 
ADM_devices_mimosa.xml > Contains all device and path information for the PRM 
integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

B. Close the “DTM Works” and the “PRM Setup Tool”. 

C. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

D. Press [Open PRM Hierarchy]. Log-in dialog appears. 

E. Enter log-in data and confirm with [OK]. 

F. Press [Open Import file]. 

G. In the drop-down list, choose FDS and confirm with [OK]. 

H. Choose file “ADM_devices_mimosa.xml” from the export folder you created in 
action A. and press [Open].  

I. Drag and drop the node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure to create this 
structure project-specifically first. 
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J. In appearing dialog “Merge Hierarchy Info”, check that the segments are marked 
with type “CONTROL MODULE” within the “Type Selection” column. 

 
K. Confirm with [OK]. 

L. Press [Upload to database] button ( ) in toolbar. 

M. Close “Hierarchy Import Tool”. 
 
 

8.3 Remove Advanced Diagnostic Modules or 
Segments 

Make sure that the new file DevicePath.txt is available. 

A. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Right-click on the node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

D. Double-click on the node FieldConnex® Diagnostic Server (PRM) in FDT 
Topology window. 

E. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

F. Press button [Read Device Path File]. Browse to your project folder and choose 
the Device Path File. Confirm message box with [Ok]. 
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G. Choose all segments to be monitored with ADM, exclude the Channels/Slots you 
want to delete from the current configuration. 

 
H. Press [Ok] to continue. 

I. Press [Set topology] button in toolbar. 

J. Close the “DTM Works” and the “PRM Setup Tool”. 

K. Start PRM ([Start] > [All Programs] > [YOKOGAWA PRM] > [Plant Resource 
Manager]). 

L. Search within the topology for the excluded Channels/Slots. Right-click on the 
node and choose “Delete”. 
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8.4 Shift Advanced Diagnostic Modules to Other 
Ports 

Make sure that the new file DevicePath.txt is available. 

A. Start the "PRM Setup Tool" on Field Communication Server by selecting [Start] > 
[PRM Tools] > [PRM Setup Tool].  

B. From the node „Field Communication“, open the project created during initial 
setup. 

C. Right-click on the node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

D. Double-click on the node FieldConnex® Diagnostic Server (PRM) in FDT 
Topology window. 

E. The Offline-parameterization window appears. Choose tab [FDS Topology 
Settings]. 

F. Right-click on the required “HD2-DM-A” node and select “Move ADM to next Port” 
from the appearing popup menu. 

 
G. Alternatively, the required “HD2-DM-A” node can be dragged with the mouse 

directly to the target port. 

H. If necessary adapt the address of the moved “HD2-DM-A”. 

I. Press [Apply] and afterwards press [Set topology] in toolbar. 

J. Press [Export for PRM] in toolbar. Adapt “Output Folder” if necessary and press 
[Export]. 

↳ Three files are created at the output folder: 
ADM_devices_mimosa.xml > Contains all device and path information for the 
PRM integration 
Report.pdf > Device installation/identification document 
ADMBitmap.bmp > Icon for PRM integration 

K. Open [File] menu and press [Save FDT Project]. 
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L. Close the “DTM Works” and the “PRM Setup Tool”. 

M. Start “Hierarchy Import Tool” (by default “C:\PRM\Program\HierarchyImport.exe”). 

N. Press [Open PRM Hierarchy]. Log-in dialog appears. 

O. Enter log-in data and confirm with [OK]. 

P. Press [Open Import file]. 

Q. In the drop-down list, choose FDS and confirm with [OK]. 

R. Choose file “ADM_devices_mimosa.xml” from the export folder you created in 
action J. and press [Open].  

S. Drag and drop the node “FFH1 Advanced Diagnostics” from the right window into 
“PLANT” in the left window. The node here is an example. Ensure to create this 
structure project-specifically first. 

 
T. In appearing dialog “Merge Hierarchy Info”, check that the segments are marked 

with type “CONTROL MODULE” within the “Type Selection” column. 

 
U. Confirm with [OK]. 

V. Press [Upload to database] button ( ) in toolbar. 

W. Close “Hierarchy Import Tool”. 
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9. Field Device Tag Import into 
Diagnostic Manager 

The Diagnostic Manager provides a function to take over field device tag 
information from PRM to show the device tags at the Diagnostic 
Module/Diagnostic Manager, too. 

9.1 Tag Import 
A. Start PRM ([Start] > [All Programs] > [YOKOGAWA PRM] > [Plant Resource 

Manager]). 

B. Choose [File] > [Export] > [Maintenance Info]. 

 
C. Select “Browse…” in dialog window “Export Maintenance Info”. 

D. Activate “Select” option and afterwards “Class View” option. 

E. Select all FOUNDATION Fieldbus devices and proceed with [OK]. 
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Note 

 Device Tag Information 
All FOUNDATION Fieldbus device tag information has to be exported. 

F. Select “Device” as only option in “Export Items” group. 

G. Press [OK] to start export. 

 
H. Export is in progress. 

 
I. Close PRM. 

J. Start the „PRM Setup Tool“ on the Field Communication Server by selecting [Start] 
> [PRM Tools] > [PRM Setup Tool]. 

K. From the node „Field Communication“, open the project created during initial 
setup. 

L. Right-click on the node FieldConnex® Diagnostic Server (PRM) in FDT Topology 
window and choose “Connect” to set the DTM online. 

M. Double-click on the node FieldConnex® Diagnostic Server (PRM) in FDT 
Topology window. 

N. The Offline parameterization window appears. Choose tab [FDS Topology 
Settings]. 

O. Press button [Import Device Tags]. 
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P. Choose the “PRM_MaintenanceInfo_YYYYMMDD.xml” (file name contains date) 
exported in action G. 

Q. Confirm message box with [OK]. 

R. Tag information is visible in topology tree now. 

 
S. To take over tag information into the Diagnostic Manager a run-through of the 

commissioning wizard is required (see chapter 9.2). 
The figure below shows a comparison between PRM and Diagnostic Manager 
after commissioning wizard is completed. The field device tags now are consistent 
in both systems. 

 
 

 
Note 

 Device Tag Information in the Diagnostic Manager 
Do not change field device tag information within Diagnostic Manager. 
Changes cannot be synchronized with PRM out of the Diagnostic 
Manager/Advanced Diagnostic Module. 

 

9.2 Commissioning Wizard Additional Information 
During commissioning of the Advanced Diagnostic module with the 
commissioning wizard, it is possible to store the field device tag information in the 
Advanced Diagnostic Module. 
By default, the imported tags are already visible at the “Field Device Tags” 
commissioning wizard page. The only thing to do is to verify this information and 
to complete commissioning (see also manual of Diagnostic Manager). 
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