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1

Introduction

1.1

Product Description
The Wireless Network Checker (WiNC) is a radio network planning suite. It
enables you to create 3-D models of plants and to calculate the wave propagation
and connectivity of WirelessHART networks based on these 3-D models.
The connectivity suite consists of the following components:
■
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■

WiNCMod enables you to create and edit 3-D models of almost any plant
or building. Depending on your application, you can freely adjust the level
of detail of the 3-D models from basic overviews to highly complex
structures.
WiNCSim enables you to simulate the wave propagation and connectivity
between the individual network nodes. You can import the 3-D models from
WiNCMod and simulate different network topologies by placing the
WirelessHART devices directly into the 3-D model.
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Installation

2.1

System Requirements
Your personal computer must meet the following requirements in order to run
WiNC:
■
■
■
■
■
■

2.2

Operating system: Windows 98 or newer
Processor: 1 GHz or faster
Memory: 512 MB or more
Disk space: 500 MB or more
Software: DirectX 9 or newer
Administrator privileges to enable software installation

Software Installation
This section describes how to install WiNC and the USB license key, which is
required to run the complete software without limitations. Note that you must plug
the USB license key into your personal computer before you start WiNCMod or
WiNCSim. If the USB license key has been recognized, the license key icon
in
the taskbar turns green and you can start using WiNCMod or WiNCSim.
If you start WiNCMod or WiNCSim without using a USB license key, the software
starts in trial mode with reduced functionality. In trial mode, the size of the 3-D
models in WiNCMod is limited and the number of network nodes you can insert
into the 3-D model using WiNCSim is limited as well.

Install Components
1. Start the installer by Pepperl+Fuchs.

Figure 2.1
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Setup window
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The SETUP window appears.

Wireless Network Checker
Installation

2. Select Wireless Network Checker and select a driver for the USB license
key that matches your operating system.
3. Click Install select application(s) to continue.
4. In the following popup window, click Yes to install WiNC.
5. Click Next to continue.
6. If you accept the license agreement, activate the I accept the terms in the
License Agreement check box and click Next to continue.
7. Enter your user name, organization, and the serial number from the SETUP
screen and choose Next to continue.
8. Select a setup type by clicking Typical, Custom, or Complete.
Note that the setup types Typical and Complete copy all files into the
following directory: C:\Program Files\Pepperl-Fuchs\
9. Decide whether you want to create shortcuts and choose Next to continue.
10. Choose Install to start the installation process.
11. Choose Finish to complete the installation process.
WiNC has been installed.
12. In the following popup window, click Yes to install the drivers for the USB
license key.
13. Choose Next to continue.
14. If you accept the license agreement, activate the I accept the terms in the
license agreement option and choose Next to continue.
15. Enter your details in the User and Organization boxes.
16. Choose Next to continue.
17. If required, deselect individual components. We recommend that you use the
default settings.
18. Choose Next to continue.
19. Choose Install to start the installation process.
20. Choose Finish to complete the installation process.
The driver for the USB license key is installed.
21. Click Quit to close the installer window.
22. Plug the USB license key into your personal computer before you start
WiNCMod or WiNCSim.
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If the USB license key has been recognized, the license key icon
in
the taskbar turns green and you can start using WiNCMod or WiNCSim.
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WiNCMod
WiNCMod enables you to create and edit 3-D models of your plants.

3.1

Create New 3-D Model
All elements of a 3-D model are stored in a database. The database contains all
objects and properties of the 3-D model.

Create New Database
1. Click

New Database or choose File > New Database.

The Select Type of New Database window opens.
2. In the Mode of operation area, select Draw manually.
3. In the Material catalogue area, you can specify an additional material
catalog from which you can choose materials for the objects in your 3-D
model. See chapter 3.20
4. Click OK.
The Default Values for New Objects window opens.
5. The Default Values for New Objects window enables you to define the
floors of the working area and the default materials for new walls. Note that
you can change these settings later on. To do so, choose Edit > Default
Values. See chapter 3.2
6. Click OK.
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The working area opens.
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3.2

Set Default Values for New Objects
The default settings define the material properties and height for new objects.

Set Default Values
1. Choose Edit > Default Values.
The Default Values for New Objects window appears.

Figure 3.1

Default Values for New Objects window

2. Select a drawing mode in the Geometrical Parameters for Orthogonal
Drawing Mode area.
3. Select the material properties for new walls and subdivisions in the Material
Properties area.
4. Click OK to confirm the default values for new objects.
Geometrical Parameters for Orthogonal Drawing Mode
Option

Description

Object relative to current plane

Enables you to set the height for new
objects manually. Note that you must use a
dot as decimal separator.

Upper and lower coordinate defined
individually

All objects on a specific floor level will
automatically inherit the height of the floor.
To define individual floors, click Floor
Levels. See chapter 3.3
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Automatic mode
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Tip
If you define individual floor levels, you can easily switch between different layers
in the working area. Note that floor levels are available only if the orthogonal
drawing mode is set to Automatic mode. See chapter 3.3
Material Properties
Option

Description

Material properties of new walls

Enables you to define the material for new
objects and subdivisions. For example,
select Stone in the Material Properties of
new Walls drop-down list and select
Glass in the Material Properties of new
Subdivisions drop-down list.
To edit the material catalog, click Add /
Edit Materials. See chapter 3.20

Material Properties of new
Subdivisions

3.3

Define Floor Levels
Note that floor levels are available only if the orthogonal drawing mode is set to
Automatic mode in the Default Values for New Objects. See chapter 3.2

Define Floor Levels
1. Click
Floor Levels or choose Edit > Default Values > Floor Levels to define individual floors.
The Floor Levels Above Ground window appears.

Figure 3.2

Example of different floors. Note that the floors do not have to be
identical to the actual levels.

2015-01

2. Click Add to define new floor levels.
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3. Enter the height for each floor from ground level. Note that you must use a dot
as decimal separator.

Figure 3.3

Floor heights

4. Enter a description for the new floor level. The description will appear in the
Floor Levels Above Ground drop-down list of the View Toolbar.
5. Click OK.
6. After you defined all floor levels, click OK to close the Floor Levels Above
Ground window.

3.4

Convert Existing 3-D Models
As an alternative to creating a whole new database, you can also import and
convert existing models from other programs.
You can convert the following data:
■
■
■
■
■
■

WinProp Indoor Building Data ASCII (*.ida)
AutoCAD File Format (*.dwg, *.dxf)
Facet File Format (*.fac)
Stereolithography File Format (*.stl)
Nastran File Format (*.nas)
Wavefront File Format (*.obj)

Convert an Existing 3-D Model
1. Choose File > Convert Indoor Database > Vector Database.
The Conversion of Indoor Vector Database window appears.
2. Select the format of the source file in the Format of Database area.
3. To simplify the database by combining adjacent walls or objects, activate
Simplification of Walls/Objects. You can define detailed settings for
simplification by clicking Settings.
4. To display a detailed log during the conversion process, activate Extended
Messages in Progress Window.
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5. To open the database after it has been converted, activate Load Database
after Conversion.
6. Click OK.
7. Select the source file and click Open.
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8. Enter a new file name for the converted database and click Save.
The Transformation of database window appears.
9. If required, you can rotate, shift, or scale the objects of the database you are
about to convert.
10. Click OK.
The Progress window appears. Note that depending on the database you
convert, further windows may open where you have to define additional
settings, such as, the layers that have to be converted, or the height of the
converted objects.
Tip

Figure 3.4

3-D view is correct although the XY view plane appears to be empty

If the color of the imported materials is set to white, the working area on the left
appears empty although the database has been converted correctly. In this case,
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click
Materials used in database or choose Edit > Materials to open the
material catalog and edit the color definition. See chapter 3.20

12

Wireless Network Checker
WiNCMod

3.5

Define Global Settings
Define Global Settings
1. Click
Change Settings in the Standard Toolbar or choose Edit > Settings to define the global settings.
The Settings window appears.

Figure 3.5

Settings window

2. To display a grid in the working area, activate Grid in the Drawing Help area.
Note that you can also use the
Grid button in the View Toolbar to activate
or deactivate the grid directly from the working area.
If Grid is activated, you can enter a customized grid size.
3. To make all objects snap to the grid, activate Catch Points in the Drawing
Help area.
Note that you can also use the
Catch Points button in the View Toobar to
activate or deactivate this option directly from the working area.
If Catch Points is activated, you can enter a customized catch range.
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4. To change the number of steps you can undo, enter a number into the Size of
UnDo buffer box.
5. If necessary, define additional settings in the Acceleration of Display,
General Display Options, and Display Options for Indoor Databases
areras.
6. Click OK to confirm the settings.
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Tip
Select the grid size depending on the simulation. For indoor simulations, we
recommend that you use a maximum grid size of 0.2 m. In this case, the
difference between the real distance of two objects and their distance in the
working area is limited to a maximum of 0.4 m. For simulations in large outdoor
areas, you can use a larger grid size.
Acceleration of Display
Option

Description

All acceleration options always
enabled

Enables all acceleration options.

All acceleration options always
enabled if number of objects exceeds a
selected number of objects

Enables all acceleration options only if a
selected number of objects is reached.

Select acceleration options manually

Enables you to define individual settings
for the acceleration and the refresh of the
display. We recommend that you change
these settings only if you experience
performance issues while working with
very large databases.

General Display Options
Option

Description

Fill Objects

Switches from transparent wire frame
display to non-transparent display.

Show Object Numbers

Displays the object numbers in the working
area.

Colorize Materials

Displays each material in the color defined
by the material catalog.
Note that you can also use the
Indiv.
color for each material button in the
View Toolbar to activate or deactivate the
display of individual material colors directly
from the working area.
Displays the coordinate system in the
working area.

Auto Scroll

Activates automatic scrolling when you
draw an object that exceeds the working
area.

Show 3D View

Activates the three-dimensional view on
the right side of the screen.
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Mark Origin
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Display Options for Indoor Databases
Option

Description

Show XZ and YZ Views

Displays all side views in the working area.

Report intersections of walls

Displays a warning message when two
walls intersect. Note that the various
drawing tools behave differently regarding
this setting. Not all tools will automatically
report an error message.

Display walls parallel to display plane

Displays walls that are parallel to the
current display plane.

Display Thickness of Walls

Displays the thickness of walls in the top
view.
Note that you can also use the
Show
thickness button in the View Toolbar to
activate or deactivate the display of the wall
thickness directly from the working area.

3.6

Standard Toolbar
The Standard Toolbar contains basic commands for database handling and
setup.
Command

Description
New Database
This command enables you to create a new database. See chapter 3.1
Open Database
This command enables you to open an existing database.
Save Database
This command enables you to save the current database.
Print Database
This command enables you to print the current database.
Delete
This command deletes currently selected objects.
Cut
This command cuts out currently selected objects.
Copy
This command copies currently selected objects.
Paste
This command inserts an object that has previously been cut out or
copied.
Undo
This command enables you to undo the last steps. Note that you can
define the number of steps that can be undone in the global settings.
See chapter 3.5
Redo
This command enables you to redo a step that you've undone before.
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Materials used in database
This command opens the material catalog for the current database.
See chapter 3.20
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Command

Description
Open Group Manager
This command opens the group manager. See chapter 3.17
Change Settings
This command enables you to define global settings. See chapter 3.5
About
This command displays information about the program and contact
information.

3.7

View Toolbar
The View Toolbar contains the following tools:
■

■
■

Display tools that enable you to control the display of objects in the working
area
Layer tools that enable you to edit different layers of the working area
Additional tools that enable you to control rulers, a background image etc.

Display Tools
Tool

Description
X-Y Plane
This tool enables the XY view of the working area in the currently active
window.
X-Z Plane
This tool enables the XZ view of the working area in the currently active
window. Note that this tool is available only if Show XZ and YZ Views
has been activated in the global settings. See chapter 3.5
Y-Z Plane
This tool enables the YZ view of the working area in the currently active
window. Note that this tool is available only if Show XZ and YZ Views
has been activated in the global settings. See chapter 3.5
3D View
This tool enables the 3-D view of the working area in the currently
active window.
Zoom In
This tool enables you to zoom into the working area of the currently
active window.
Zoom Out
This tool enables you to zoom out of the working area of the currently
active window.
Zoom Window
This tool enables you to draw a selection area that the window zooms
into.
Mouse Pan and Zoom Tool
This tool enables you to displace the working area.

2015-01

Zoom Selected Objects
This tool makes selected objects of the working area fit into the
currently selected window. Note that you must create a selection first.
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Tool

Description
Fit to screen
This tool makes all objects of the working area fit into the currently
selected window.
Redraw all objects
This tool rebuilds all objects in the working area. If you experience
display issues, for example in 3-D mode, choose redraw all objects to
refresh the display.

Layer Tools
Tool

Description
3rd Coordinate Settings
This tool enables you to define the 3rd coordinate relative to the current
plane. See chapter 3.10

Floor Levels Above Ground
This drop-down list enables you to select a floor level. Note that the drop-down list is
available only if the orthogonal drawing mode is set to Automatic mode in the Default
Values for New Objects. See chapter 3.3
Floor Levels
This tool enables you to define the floor levels for the automatic
orthogonal drawing mode. See chapter 3.3

Additional Tools
Tool

Description
Indiv. color for each material
This tool activates and deactivates the display of individual material
colors in the working area. Note that the material colors are defined in
the material catalog. See chapter 3.20
Show thickness
This tool activates or deactivates the display of the wall thickness. Note
that the wall thickness depends on its material. The thickness of each
material is defined in the material catalog. See chapter 3.20
Goto Position
This tool enables you to display a defined position of the working area
by entering its X, Y, and Z coordinates.
Image Configuration
This tool enables you to define a background image for the working
area. See chapter 3.11
Move Image
This tool enables you to move the current background image. See
chapter 3.11
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Scale Image
This tool enables you to resize the current background image. See
chapter 3.11
Marker Points
This tool enables you to insert marker points in the working area, which
enables you to keep track of large projects. To edit an existing marker
point, activate Marker Points and right-click the marker point in the
working area.
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Tool

Description
Catch Points
If activated, each object you draw in the working area will automatically
snap to the grip. Note that you can define the size of the grid in the
global settings. See chapter 3.5
Grid
If activated, the grid is displayed in the working area. Note that you can
define the size of the grid in the global settings. See chapter 3.5
Call Mouse Meter Tool
This tool allows you to measure distances directly in the working area.
See chapter 3.18
Rotate Single Wall View
This tool enables you to rotate the currently active window by 90°.
Rotate Single Wall View
This tool enables you to enter a rotation angle for the currently active
window.
Flip Single Wall View
This tool enables you to flip the currently active window around its
vertical axis.

3.8

Objects Toolbar
The Objects Toolbar consists of two parts:
■
■

Selection tools
Drawing tools

Selection Tools
Tools

Description
Select Object
This tool enables you to select a single object in the current plane.
Select Multiple Objects
This tool enables you to select multiple objects in the current plane.
Note that this tool does not select objects that reside above or below
the current plane.
Select Multiple Objects 3D
This tool enables you to select multiple objects in all planes, including
the objects above or below the current plane. After you created a
selection in the working area you can define the height above and
below the selection.
Freehand Selection
This tool enables you to create an arbitrary selection to select multiple
objects in the current plane.
Select Objects with same Material Properties
This tool enables you to select all objects of the same material in all
planes. See chapter 3.15
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Find Object by Number
This tool enables you to select a single object by its object number.
Note that if the object is located above or below the plane you are
viewing, you may not see the selection. See chapter 3.16
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Note!
If you use the three-dimensional selection tool or if you select objects by material
or number, note that the selection may include objects that are not visible in the
current view plane. See chapter 3.10
Tip
To invert the current selection, choose Objects > Invert Selection.
Tip
To combine different selections, make the first selection, then press and hold the
control key CTRL on the keyboard and make another selection.
Drawing Tools
Tool

Description
Polygonal Object
This tool creates a two-dimensional surface of any shape.
Polygonal Object with Orthogonal Walls and Ceiling
This tool creates a three-dimensional cube of any shape.
Rectangular Object
This tool creates a two-dimensional rectangle, such as a floor or a
ceiling.
Orthogonal Object
This tool creates a two-dimensional rectangle in an orthogonal plane,
such as a wall.
Pipe
This tool creates a three-dimensional, open pipe.
Cylinder
This tool creates a three-dimensional, solid cylinder in an orthogonal
plane, such as a reservoir.
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Sphere
This tool creates a three-dimensional sphere, such as a gas tank.
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3.9

Navigate in Views
Navigate in 2-D Views
1. Use the scrollbars to move the view.
2. Use the mouse wheel to zoom in or out.
3. For more options, use the tools from the View Toolbar.

Navigate in 3-D View
Note!
Note that the tools from the View Toolbar do not apply to the 3-D view.
1. Click and hold the left mouse button to move the 3-D view.
2. Click and hold the right mouse button to tilt the 3-D view.
3. Click and hold both mouse buttons to rotate the 3-D view.
4. Use the mouse wheel to zoom in or out of the 3-D view.
5. Click Total View to restore the initial 3-D view.
6. Click Store to store the current 3-D view.
Note that you can store multiple views. Each view is listed in the Live Camera
drop-down list.
7. Click Live Camera to display a drop-down of all 3-D views that have been
stored before.

2015-01

8. To delete a 3-D view that has been stored before, select the view from the
Live Camera drop-down list and click Delete.
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3.10

Working with Layers
When creating and editing objects in the working area, be aware that the working
area resp. the current view plane is just a single layer of the actual database. You
only see the intersections of objects with the view plane. Objects below or above
the view plane are invisible. If you want to view or edit an object that is currently
invisible, you must move the view plane until it intersects the object.

Figure 3.6

Object intersections with the working area

New objects will automatically be placed in the current view plane, because the
working area corresponds to the current view plane. You can easily create new
objects in different layers by moving the view plane. If you frequently move the
view plane, make sure that it is in the right position before you create a new object.
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Each window displays a discrete plane, for example the XY plane. By default,
each view plane is displayed as a violet layer in the 3-D view.

Figure 3.7

XZ, XY, and YZ view planes. Each view plane is displayed as a violet layer in
the 3-D view.
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You can move each view plane along its third axis. The object intersections are
updated while you move the viewing layer.

Figure 3.8

XZ, XY, and YZ view planes. The XY view plane has been moved along the Z
axis.

Move the Working Area
1. Click

3rd Coordinate Settings.

The 3rd Coord Settings window for the currently active window appears.
2. Use the slider to move the view plane. By default, you can move the slider
only to the extent that there are objects in the working area. For example, if the
height of the highest object is 10 m, you cannot move the slider further than
10 m.
3. To move the view plane stepwise, activate a value in the Snap area.
4. To increase or decrease the area in which you can move the current view
plane, enter a maximum and minimum value in the Max and Min fields of the
3rd Coord area. For example, if you want to create a new object, which is
located 5 m above the highest object, you can increase the maximum value
by 5 m. Then you can move the view plane to the new maximum value and
create the new object.
5. To define an individual anchor, enter a value in the Marks area and click Add
Mark. To move the view plane to a defined anchor, double-click the anchor
value in the Marks area.
To delete an anchor, select the anchor in the Marks area and click Delete
Mark.

22
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6. Activate Show Marks in 3D to display anchors as a red layer in the 3-D view.
7. Activate Show 3rd Coord in 3D to display each view plane as a violet layer in
the 3-D view.
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Tip
If you're working in multiple layers and need to change the view plane often, click
<< to minimize the 3rd Coord Settings window. This way the window occupies
less space and remains on top of the view planes while giving you direct access to
the slider.

3.11

Define Background Images
You can define multiple background images for each view plane. The background
images of the XY plane are also displayed in the 3-D view.
Tip
If you create a new 3-D model of a plant or building, we recommend that you use a
floor plan as background image for the XY plane. This enables you to retrace the
walls and objects of the floor plan directly in the working area.

Define Background Images
1. Click
Image Configuration or choose Images > Configuration to upload
a background image.
The Image Configuration window appears.
2. Click Add to upload a new background image.
3. Select an image file and click Open.
4. To edit the coordinates, width and height settings of an image file, select the
image file in the Image Files area and edit its settings in the Image
Properties area.
5. Click Close.
If the entire background consists of multiple images, add all images to the Image
File area and define the coordinates, width and height settings of each image file
in the Image Properties area. Click Apply to confirm the settings before you
select another image file.
To move the background image manually without entering its exact coordinates,
click
Move Image in the View Toolbar. Then click into a background image
and hold the left mouse button to move the background image in the working area.
To scale the background image manually without entering its exact width and
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height, click
Scale Image in the View Toolbar. Then click into a background
image and hold the left mouse button to scale the background image in the
working area.
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3.12

Create Simple Objects
The Objects Toolbar enables you to draw basic objects that can represent entire
buildings, walls, or furnishings and equipment.
Select the level of detail depending on the simulation. If you simulate wave
propagation inside a building, we recommend that you create walls, floors and
ceilings by drawing individual objects. If you simulate wave propagation in large
outdoor areas where the inside of a building is less important, you can abstract
entire buildings by drawing three-dimensional polygonal cubes.

Draw Simple Objects
1. Select a drawing tool from the Objects Toolbar.
2. Click into the working area to activate the working area and click again to set
the starting point for the object.
3. Click again to draw the object.
If you draw a polygonal object, you can draw an arbitrary number of corners
by clicking into the working area. To complete the polygonal object, click into
the working area using the right mouse button.

3.13

Create Complex Objects using Subdivisions
To increase the level of detail, you can add subdivisions to most basic objects.
Note that each subdivision can have its own material properties. To change the
material properties of the subdivisions, see chapter 3.14.
You can also create holes using subdivisions. You can also turn a subdivision into
a hole and vice versa by changing its material properties.
Example!
To create a wall with a door and a window, you draw a regular wall and then you
draw subdivisions onto the wall that represents the door and the window.
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1. Wall
Material: concrete
2. Subdivision: door
Material: wood
3. Subdivision: window
Material: glass
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Create a Subdivision
1. Select an object in the working area using one of the selection tools. For example, select a wall.

Figure 3.9

Wall in the XY view plane

The selected object is highlighted.
2. Double-click the selected wall to switch from top view to side view enabling
you to draw a new object on the selected object. You can also switch views
using the tools of the View Toolbar. See chapter 3.7

Figure 3.10

Wall in the XZ view plane

The view switched from XY plane to XZ plane and you can see the side
view of the wall.
3. Select a drawing tool from the Objects Toolbar. For example, select the
Rectangular Object tool.
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4. Draw a new object on the first object.

Figure 3.11

Draw subdivison on the object.

The Insert Subdivision window appears.
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5. Select Create subdivision with own material properties to create
subdivisions, such as doors, or windows.
Select Create hole in surrounding wall to create an opening.
6. Click OK.

3.14

Define Object Properties
The object properties define the type of the object, its material, and its spatial
definitions.

Define Material Properties
Note!
Note that the choice of materials depends on the material catalog. See chapter
3.20
1. Select an object or subdivision in the working area using one of the selection
tools.
The selected object or subdivision is highlighted.
2. Right-click the highlighted object or subdivision and select Material
Properties.
The Material Properties window appears.
3. Select a material from the list and click OK.

Define Object Properties
1. Select an object or subdivision in the working area using one of the selection
tools.
The selected object or subdivision is highlighted.
2. Right-click the highlighted object or subdivision and select Properties.
The Object Properties window appears.
3. To turn a subdivision into a hole and vice versa, click Change Type.
4. Select a material from the drop-down list in the Material Parameters area.
5. You can enter a comment for the selected object in the Comment box.
6. You can change the shape of the selected object by adding, removing, and
editing the values in the Corners area. For example, you can turn a rectangle
into a triangle by deleting one of the corners. Note that you must not intersect
other objects when editing the shape of the current object.
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7. Click OK to update the object properties.
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3.15

Select Objects by Material
Select Objects by Material
1. Select
Select Objects with same Material Properties from the Objects
Toolbar or choose Objects > Select Multiple Objects (Material).
The Material window appears.
2. Select a material from the drop-down list.
3. Click OK.
All objects with these material properties are selected and highlighted.

3.16

Select Objects by Number
All objects in the working area can be identified by their object number. To display
the object number in the working area, activate the option Show Object
Numbers in the General Display Options area of the global settings. See
chapter 3.5

Select Objects by Number
1. Select
Find Object by Number from the Objects Toolbar or choose Objects > Select Single Object (Number).
The Find Object window appears.
2. Enter the object number.
3. To display the object in side view automatically, activate Switch to single
view of this object.
4. Click OK.
The object is selected and highlighted.
Note!
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If you did not select Switch to single view of this object and if the object is
located above or below the plane you are viewing, you may not see the selection.
See chapter 3.10
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3.17

Create Object Groups
You can combine multiple objects in groups. This allows you to edit multiple
objects as a single unit. Furthermore, you can assign material properties to the
entire group.
Note!
Objects cannot belong to multiple groups at a time. Each object can belong to a
single group only.

Create Groups
1. Select the objects you want to group in the working area.
The selected objects are highlighted in red.
2. Click
Open Group Manager or choose Objects > Group Manager to
open the group manager.
The Group Manager window appears.
3. Click Create in the Group Manager window.
The selected objects create a new group.
4. Click Close to close the Group Manager window.

Edit Groups
1. Click
Open Group Manager or choose Objects > Group Manager to
open the group manager.
The Group Manager window appears.
2. To add additional objects to the group, select the objects in the working area
and click Add in the Group Manager window.
3. To delete an object from the group, select the object in the right column of the
Group Manager window and click Del.
4. To combine multiple groups to a new group, press and hold the control key
CTRL on the keyboard, select the groups in the left column of the Group
Manager window, and click Combine.
5. To group all objects of the working area by their material properties, click by
Material. Note that if you group all objects by material, existing groups may be
deleted automatically.
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6. Click Close to close the Group Manager window.
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3.18

Measure Distances
You can measure distances directly in the working area.

Measure Distances in the Working Area
1. Click

Call Mouse Meter Tool in the View Toolbar.

2. Click into the working area using the left mouse button to set the starting point
for the measurement.
3. Move the cursor to measure the distance between the current cursor position
and the starting point.
The distance between the starting point and the current cursor position,
as well as the coordinates of the current cursor position are displayed
automatically.

Figure 3.12

Mouse Meter in XY view plane

4. To start a new measurement, click into the working area using the left mouse
button.
5. To stop using the Mouse Meter, click into the working area using the right
mouse button or press the escape key Esc on the keyboard.
Tip
To measure the height of objects, use the Mouse Meter in the side view, for
example, in the XZ view plane.
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Note that the side views are available only if Show XZ and YZ Views has been
activated in the global settings. See chapter 3.5

Figure 3.13

Mouse Meter in XZ view plane
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3.19

Scale Objects
You can resize all objects in the database including the background images at any
time.

Scale all Objects by Drawing a Line
Tip
Scale all objects by drawing a line to create a true to scale representation.
1. Choose Edit > Scale All Objects.
The Scale Objects window appears.
2. Make sure the option By drawing a line is activated in the Selection of
scaling method area.
3. Deactivate unwanted directions in the Scale walls area.
4. If the background image is already true to scale, deactivate Images in the
Scale other objects area.
5. Click OK to close the Scale Objects window.
6. Click OK to close the pop-up window.
7. Draw a line in the working area. For example, redraw a wall in the working
area or in the background whose dimensions are known.
The Scale window appears.
8. Enter the length of the line you have drawn. All objects will be resized
according to the value you specify for this line. Note that you must use a dot
as decimal separator.
9. Click OK to close the Scale window.
10. Click Yes to confirm.
All objects in the database have been resized.

Scale all Objects using a Scaling Factor
1. Choose Edit > Scale All Objects.
The Scale Objects window appears.
2. Activate With known scaling factor in the Selection of scaling method
area.
3. Enter the scaling factor in the Factor box. Note that you must use a dot as
decimal separator. For example, enter 2 to double the size of all objects in the
working area.
4. Deactivate unwanted directions in the Scale walls area.

6. Click OK to close the Scale Objects window.
7. Click Yes to confirm.
30
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5. If the background image is already true to scale, deactivate Images in the
Scale other objects area.
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All objects in the database have been resized.
Instead of scaling all objects at once, you can also scale selected objects only.
Select multiple object in the working area using one of the selection tools. Choose
Objects > Scale selected objects and proceed as described before.

3.20

Edit Material Catalog
WiNCMod comes with a predefined material catalog, which enables you to select
from a wide range of materials when creating your database. Note that each
material has its own electrical properties.
If you are missing a special material, you can edit the material catalog and create
customized materials.

Edit Materials
1. Click
Materials used in database or choose Edit > Materials to open the
material catalog.
The Material Catalogue window appears.
2. To add a new material to the catalog, click Add material. To edit an existing
material, select the material from the list and click Edit.
The Material Properties window appears.
3. Enter a name for the material in the Name box.
4. The Propagation phenomena area enables you to disable specific
calculations during the simulation. We recommend that you do not change
these settings.
5. Enter a value for the thickness in the Thickness box. This value is used to
display the thickness of objects in the working area.
6. Because electrical properties depend on the frequency, you can define
different properties for different frequencies. To add a new entry, click Add in
the Electrical Properties area. To edit or delete existing entries, select an
entry from the list and click Edit respectively Delete.
7. To select a color for the material, click into the color preview in the Color of
Material area.
8. To enable the display of objects in the material color, activate Draw object
filled on display if filled mode is selected in the Color of Material area.
9. We recommend that you do not deactivate Draw objects on screen in the
Color of Material area, because once the objects are invisible, they can no
longer be selected using the selection tools.
10. Click OK.
Tip
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If you select one or multiple object in the working area, the selected objects are
highlighted in red automatically. To avoid confusion with selected objects, you
should refrain from using red as a material color.
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You can replace materials from the current material catalog with materials from
external material catalogs.

Replace Single Materials
1. Click
Materials used in database or choose Edit > Materials to open the
material catalog.
2. Select the material you want to replace from the list and click Replace.
3. Select the material catalog that contains the new material and click Open.
4. Select the new material from the list and click Import.
The material in the material catalog of the current database has been
replaced by the material from the external material catalog.
You can import selected materials from external material catalogs or you can
import entire material catalogs.

Import Materials
1. Click
Materials used in database or choose Edit > Materials to open the
material catalog.
2. Click Import.
3. To add the comment [added] to the name of imported materials, activate
Mark descriptions of affected materials with comments.
4. To overwrite existing materials with the same description, activate Overwrite
materials with same description.
5. Select a material catalog and click Open.
The Import material from catalogue window appears.
6. Select the materials you want to import from the list and click Import. Press
and hold the control key CTRL on the keyboard to select multiple materials
simultaneously.
7. Click Import to import the selected materials.
8. Click OK to close the material catalog.

Export the Material Catalog
1. Click
Materials used in database or choose Edit > Materials to open the
material catalog.
2. Click Export to export the material catalog.
3. Enter a file name for the exported material catalog and click Save.
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4. Click OK to close the material catalog.
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4

WiNCMod Tutorial
This tutorial contains all major steps that are required to create a new factory site
from scratch using WiNCMod. In this example, the factory site comprises a large
area with multiple storage basins and a storehouse.

Figure 4.1

Overview

The following table contains some basic dimensions of the objects on the factory
site.
Object

Material

Dimensions

Storage basin (small)

Metal

■
■

Storage basin (medium)

Metal

■
■

Storage basin (large)

Metal

Height: 13 m
Diameter: 20 m
Height: 15 m
Diameter: 40 m

■

Height: 15 m
Diameter: 70 m

■

Metal

■

Diameter: 0.6 m

Storehouse (ground floor)

Brick

■

Height: 5 m

Storehouse (1st floor)

Brick

■

Height: 5 m

2015-01

Pipes
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Create New Database
1. Click

New Database or choose File > New Database.

2. Activate Draw manually in the Mode of operation area.
3. Click OK.
4. Select Object relative to current plane in the Geometrical Parameters for
Orthogonal Drawing Mode area and enter 5 m in the Height of walls
relative to current plane box.
You can also use a different drawing mode. In this example, this setting is
quite handy because each floor of the storehouse will automatically have a
height of 5 m. The height of the storage basins can be specified individually
when creating the cylindrical objects.
5. Define the default materials for new objects in the Material Properties area,
for example Brick; thickness 20 cm for new walls and Glass; thickness: 5
mm for new subdivisions. See chapter 3.13
6. Click OK.

Insert Background Image
1. Click
Image Configuration or choose Images > Configuration to upload
a background image. See chapter 3.11
2. Click Add to upload a new background image.
3. Select an image file and click Open.
4. Click Apply.
5. Click Close to close the Image Configuration window.
The background image has been defined.

Background image inserted

2015-01

Figure 4.2
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Setup the Working Area
Tip
We recommend that you insert a floor plan or a map as background image for the
working area in the XY view plane. Then you can resize the background image to
a true to scale representation, which enables you to use the background as a
template for new objects.
1. Click
Change Settings in the Standard Toolbar or choose Edit > Settings to define the global settings. See chapter 3.5
2. Activate Grid in the Drawing Help area and enter 0.5 m in the Grid Size box.
Note that you must use a dot as decimal separator.
3. Choose Edit > Scale All Objects.
4. Click OK to scale all objects including the background image by drawing a
line.
5. Click OK to close the dialog window.
6. Draw a line in the working area. We recommend that you redraw an object of
the background image whose dimensions are clearly defined. In this example,
we use the diameter of a large storage basin as a reference point.

Figure 4.3

Scaling the background

The Scale window appears.
7. Enter 70 m in the Enter length of the specified line box, because the
diameter of the large storage basins is 70 m.
8. Click OK.
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9. Click Yes to confirm.

35

Wireless Network Checker
WiNCMod Tutorial

The background image has been resized to a true to scale representation.
If you zoom into the working area, you will notice that the diameter of the small
storage basins is made up of 40 dots, which corresponds to 20 m because we
defined a grid size of 0.5 m. See chapter 3.9
You can also click
Call Mouse Meter Tool in the View Toolbar to
measure the diameter of the small storage basins. See chapter 3.18

Figure 4.4

True to scale background image

Create Ground Floor of the Storehouse
Because the wave simulation will be performed in the outside area, we can
abstract the storehouse by drawing three-dimensional cubes.
1. Click
Polygonal Object with Orthogonal Walls and Ceiling in the Objects Toolbar.
2. Click into the working area to activate the working are and click again to set
the starting point for the object. Click again to define the corners of the
building. To complete the polygonal object, click into the working area using
the right mouse button.
You can also use other drawing tools. For example, you can draw the walls
using the

Orthogonal Object tool and add a ground plate and ceiling

using the

Rectangular Object. See chapter 3.8
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In the XY view plane you see the top view of the first building. In the 3-D
view you see that you actually created a three-dimensional block. Note that
the height of this block is 5 m because we set the default height for new
objects to 5 m. See chapter 3.2
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Figure 4.5

Ground floor of the storehouse

3. Proceed in the same way to create the other sections of the building on the
ground floor.

Figure 4.6

Ground floor of the storehouse

Tip
If you notice that the 3-D view does not update automatically, click
objects to update the view manually.

Redraw all

Create First Floor of the Storehouse
The first floor is created in the same way, but on a different height. Therefore you
must move the XY plane upwards, along its third axis.
1. Click

3rd Coordinate Settings.
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2. Move the slider upwards until it says 5 m.
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The working area in the XY plane is now above the ground floor. The view
plane resp. working area is displayed as a violet layer in the 3-D view.

Figure 4.7

Moving the XY view plane along the Z axis

3. Click
Polygonal Object with Orthogonal Walls and Ceiling in the
Objects Toolbar.
4. Click into the working area to activate the working area and click again to set
the starting point for the object. Click again to define the corners of the
building. To complete the polygonal object, click into the working area using
the right mouse button. See chapter 3.8
5. Click Cancel in the Insert Subdivision window. See chapter 3.13
The first floor of the storehouse is complete.

First floor of the storehouse
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Figure 4.8
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Create Storage Basins
1. Move the slider in the 3rd Coord Settings window downwards until it says
0 m and the XY plane is on ground level again.
2. Click

Cylinder in the Objects Toolbar.

3. Click Material.
4. Select Metal; thickness 5mm and click OK.
5. Deactivate Define radius by mouse click.
6. Enter 24 in the number of corners box to increase the level of detail.
7. Enter 13 in the height box and 10 in the radius box to create a small storage
basin.
8. Click OK.
9. Click into the working area using the right mouse button to place the storage
basin in the working area. Because the background image has been resized
to a true to scale representation, you can place the storage basin directly on
its correct location in the background image.
You created a small storage basin.

Figure 4.9

Small storage basin

10. The storage basin is highlighted in red, because it is still selected. If not, use
the selection tools to select the storage basin. See chapter 3.8
11. Right-click in the working area and select Copy or press CTRL + C on the
keyboard to copy the selected storage basin.
12. Right-click in the working area and select Paste or press CTRL + V on the
keyboard to insert another storage basin.
13. Click into the working area using the right mouse button to place the storage
basin in the working area.
14. Proceed in the same way to create the other storage basins.
2015-01

The storehouse and the storage basins are complete.
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Figure 4.10

Wire frame display of the storehouse and the storage basins

Tip
To move an object in the working area, select the whole object, then click and hold
the left mouse button to move the object around. To move an object to defined
coordinates, select the whole object, right-click into the working area, select Move
selected Objects, and enter the coordinates.
Tip
We recommend that you activate Fill Objects in the global settings to check if any
walls or ceilings are missing. See chapter 3.5

Non-transparent display of the storehouse and the storage basins
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Figure 4.11
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Create Pipes
1. Click

Pipein the Objects Toolbar.

2. Click Material.
3. Select Metal; thickness 5mm and click OK.
4. Enter 0.18 in the radius box. Note that you must use a dot as decimal
separator.
5. Click OK.
6. Click into the working area to set the starting point for the pipe. Click again to
draw the pipe.
7. Proceed in the same way to create the other pipes. If there are multiple pipes
in parallel, you use copy & paste to insert multiple pipes in parallel.
The 3-D model of the factory site is complete.

Figure 4.12

Overview

Save Database
1. Choose File > Save Database As to save the 3-D model for use in WiNCSim.
2. Enter a file name and click Save.
The Progress window appears and WiNCMod saves the 3-D model to
the specified file.
Tip
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If you're unable to save the database, check whether the database contains
problematic intersections of walls with other objects. Remove these intersections
and try again.
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5

WiNCSim
WiNCSim enables you to import 3-D models from WiNCMod and to simulate
wave propagation and connectivity of WirelessHART devices in the 3-D model.

5.1

Create a New Project
Import a WiNCMod Database
1. Click

New Project or choose File > New Project.

The New Project window appears.
2. Click Browse in the Databases & Parameters area.
3. Select a WiNCMod database file and click Open.
4. WiNCSim creates a new directory for the results by default. If you want to
store the results in a different directory, enter path to the directory in the
Result Folder box in the Databases & Parameters area.
5. Click OK.
WiNCSim displays the top view of the WiNCMod database.

Top view
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Figure 5.1
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5.2

Standard Toolbar
The Standard Toolbar contains basic commands for handling the project files.

Command

Description
New Project
This command enables you to create a new project. See chapter 5.1
Open
This command enables you to open an existing project.
Save
This command enables you to save the current project.
Print
This command enables you to print the top view of the working area.
About
This command displays information about the program and contact
information.

5.3

View Toolbar
The View Toolbar contains multiple tools that enable you to control the display of
the working area.
Tool

Description
Show Rulers
This tool enables you to activate or deactivate the display of the rulers
in the working area.
Zoom In
This tool enables you to zoom into the working area.
Zoom Out
This tool enables you to zoom out of the working area.
Zoom Window
This tool enables you to draw a selection area that the window zooms
into.
Zoom Prediction Area
This tool makes the entire prediction area fit into the window.
Total View
This tool makes all objects of the working area fit into the window.
Show 3D View
This tool enables you to activate or deactivate the 3-D view.
Show Legend
This tool enables you to activate or deactivate the color legend for the
dBm ranges. Note that this tool is available only while viewing the
results of the simulation runs.
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Show Information
This tool displays basic information on the current database, for
example the maximum and minimum height of all objects in the
database.
Mouse Meter
This tool allows you to measure distances directly in the working area.
See chapter 3.18
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5.4

Edit Toolbar
The Edit Toolbar enables you to edit the settings and the display of the project
file.
Command

Description
Change Settings
This command enables you to define global settings. See chapter 5.6
Select Objects
This is the default cursor and enables you to select objects in the
working area.
Object Info
This command enables you to display additional information on the
objects in the working area. Activate Object Info and click on a
WHART device in the working area.
Show Paths
This command enables you to display the connectivity between the
individual nodes of the WirelessHART network. Note that paths can
only be displayed after you have successfully simulated network
connectivity. See chapter 5.12.2
Show Threshold
This command enables you to enter a threshold value in dBm. Values
above this threshold are automatically displayed in green, values below
are displayed in red. Note that wave propagation and network
prediction must have been performed in order to apply a threshold to
the results.

5.5

Project Toolbar
The Project Toolbar contains multiple tools to define the network nodes and to
simulate the wave propagation and network connectivity.
Tool

Description
Project Parameter
This tool enables you to overview and define basic project parameters.
See chapter 5.7
Define Prediction Area
This tool enables you to define the area in which the wave propagation
and network connectivity will be simulated. See chapter 5.8
Insert Object
This tool enables you to insert a WirelessHART device into the working
area. See chapter 5.9
Delete Object
This tool enables you to delete a WirelessHART device from the
working area. To delete a WirelessHART device, click Delete Object
and then click the device icon in the working area.
Move Object
This tool enables you to move an existing WirelessHART device in the
working area. To move a WirelessHART device, select Move Object
and then click the device icon in the working area.
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Edit Object
This tool enables you to edit the properties of a WirelessHART device
in the working area. See chapter 5.11
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Tool

Description
Compute Propagation
This tool enables you to simulate wave propagation within the current
prediction area.
Compute Network
This tool enables you to simulate the entire network in the current
prediction area. See chapter 5.12.1
Compute Connectivity
This tool enables you to simulate the connectivity between the
individual network nodes in the current prediction area. Note that the
connectivity calculation is available only after a point-to-point prediction
has been performed. See chapter 5.12.2
Cancel Computation
This tool enables you to abort the current calculation. Note that this tool
is available only during a calculation. For example, if you notice that the
calculation for the current prediction area takes too long, you can abort
the calculation, define a different prediction area, and restart the
calculation.

5.6

Define Global Settings
Click
Change Settings or choose Edit > Settings to define the global
settings.
The Settings window contains the following tabs:
■

■

■

■

■

2015-01

■

The General tab displays the file path to the directory of the current project
file and to the directory in which the results of the simulation are stored. We
recommend that you define these settings when setting up a new project
and that you do not change these settings later on. See chapter 5.1
The Display tab enables you to control the display of the two-dimensional
working area.
The Display 3D tab enables you to control the display of the threedimensional view.
The Computation tab enables you to control the usage of resources for the
simulation run. We recommend that you do not change these settings.
The Legend tab enables you to control the display of the results of the
simulation in the working area. Note that the options on this tab are
available only after you performed a simulation run.
The Information tab enables you to control the display of system-related
parameters.
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Define Display Settings for the Working Area
1. Select the Display tab.

Figure 5.2

Display tab

2. In analogy to WiNCMod you can define a height for the current view plane of
the working area. To do so, enter a value in the Display Height in 2D View
box in the General area. Note that you must use a dot as decimal separator.
Note that you only see the intersections of objects with the view plane. If there
is no intersection with an object on the specified height, the working area
appears empty. See chapter 3.10

4. The Paths area enables you to change the display of the connection paths
between the WirelessHART devices. You can change the line width and its
color and you can select the paths that shall be displayed. If you want to see
all available paths, select All paths for all nodes from the drop-down list in
the Filter area.
46
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3. Furthermore, the General area and the Databases area enable you to
deactivate or activate the display of various objects. For example, you can
deactivate the display of the WirelessHART devices or deactivate the display
of material colors in the working area.

Wireless Network Checker
WiNCSim

Define Display Settings for the 3-D View
1. Select the Display 3D tab.

Figure 5.3

Display 3D tab

2. To display the objects in transparent mode, increase the degree of
transparency in the Vector Database area.
To display the results in transparent mode, increase the degree of
transparency in the Result Database area. For example, if the results are
displayed semi-transparent, you can recognize the objects that reside below
the result layer in 3-D view.
3. To increase the display of the antennas in the 3-D view, enter a value > 1 in
the Size Factor box of the Antenna Symbols area.
To increase the display of the connection paths in the 3-D view, enter a value
> 1 in the Size Factor box of the Path Data area.
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4. To draw a border around the simulation area, activate Draw Border around
Scenario in the Miscellaneous aera.
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Define Default Values for Results
1. Select the Legend tab. Note that the options on this tab are available only after
you calculated the network prediction and selected the results in the File
Browser on the left side of the screen.

Figure 5.4

Legend tab

2. By default WiNCSim uses 14 colors to display the calculation results. To
decrease or increase the number of color ranges, decrease or increase the
Number of Margins value in the Type area. Note that you can reset the
settings in the Type area by clicking the Default button. To define your own
color palette, activate User Defined and click Configure.
3. To use a different color set, select a different palette from the Palette dropdown list in the Color Palette area.
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4. To define the upper and lower end of the scale, enter the minimum and
maximum values in the Minimum and Maximum boxes of the Range area.
Note that you can reset the settings in the Range area by clicking the Default
button.
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5.7

Define Project Parameters and Prediction Parameters
The System Configuration window contains the following tabs:
■

■

■

■

The Network tab displays basic network information, such as the network
name and the number of instances that are considered during simulation
(time stamps). We recommend that you do not change these settings.
The System tab enables you to define an additional noise level in case of
coexisting networks.
The Nodes tab displays an overview of all network nodes respectively all
WirelessHART devices in the working area. You can edit the device
properties directly from this tab page. See chapter 5.11
The Prediction tab enables you to modify the simulation parameters, such
as the prediction area (e.g. point-to-point prediction) or the prediction
model.

Define Prediction Area and Prediction Model
1. Click
Project Parameter in the Project Toolbar or choose Project > Parameter.
The System Configuration window appears.
2. Choose Prediction.
The Prediction settings appear.

Prediction tab

2015-01

Figure 5.5
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3. To calculate wave propagation for the positions of each WirelessHART
device, activate Node Locations in the Simulation Area area.
To calculate wave propagation for the entire simulation area in a defined
height, activate Total Area in the Simulation Area area.
To calculate wave propagation for a selected prediction area in a defined
height, activate Rectangular Area in the Simulation Area area.
If you selected Total Area or Rectangular Area, you must specify the height
for which the results will be calculated. Enter the height in the Prediction
Height(s) box in the Simulation Area area. You can also specify multiple
heights at a time. Note that you must use a dot as decimal separator and a
space character to separate multiple values. See chapter 5.12
4. Select a prediction model from the Prediction Model drop-down list in the
Prediction Model area.
If you calculate wave propagation for the total area or a selected area, we
recommend that you use the Dominant Path Model (DPM) or the Multi-Wall
Model (COST 231). While the Multi-Wall Model (COST 231) only
calculates the absorption caused by different materials and structures, the
Dominant Path Model (DPM) also takes into account the reflections caused
by some materials. Thus, the Dominant Path Model (DPM) is more accurate
but the calculation takes more time.
If you calculate wave propagation for the node locations, we recommend that
you use the 3D Standard Ray Tracing (SRT) model.
5. Enter the resolution for the calculation in the Resolution box in the
Simulation Area area. The smaller the resolution, the more accurate the
prediction results. However, the calculation takes more time when increasing
the resolution. We recommend that you use a resolution > 1 m.
6. Select the results you want to be calculated in the Results area. Note that the
calculation process takes more time, the more results you select.
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7. Click OK to confirm the current settings and to close the System
Configuration window.
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5.8

Define Prediction Area
The prediction area is displayed as a red rectangle in the working area. The
default prediction area comprises the entire database you imported from
WiNCMod.
Tip
If possible, we recommend that you narrow the prediction area for large
databases with a high level of detail to reduce the time for the calculation.

Define Prediction Area
1. Click
Define Prediction Area in the Project Toolbar or choose Project >
Define Prediction Area (Rectangle).
2. Click into the working area and draw a rectangle.
3. Click into the working area to define the new prediction area.
The new prediction area is displayed as a red rectangle in the working
area.

Figure 5.6

5.9

Top view

Insert WirelessHART Devices
Available Devices
Device Icon

Description
WirelessHART gateway

2015-01

WirelessHART adapter
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Device Icon

Description
WirelessHART temperature converter

Generic WirelessHART device

Directional antennas are displayed as an arrow, while omnidirectional antennas
are displayed as a circle. Note that the antenna types of the WirelessHART
gateway, WirelessHART adapter, and WirelessHART temperature converter are
already predefined. You can edit the antenna settings such as its orientation in the
object parameters. See chapter 5.11
The following table shows the relationship between the orientation of the device
icons in WiNCSim and the actual orientation of the device.
Device Orientation
Icon Orientation

Device Orientation

WirelessHART
adapter

WirelessHART temperature converter

WirelessHART gateway

WirelessHART
adapter

WirelessHART
temperature
converter

WirelessHART
gateway

2015-01

For detailed information on the antenna gain, see Installation > Antenna
Characteristics in the manual of the device.
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Insert Device
1. Click
Insert Object or choose Project > Object > Insert to insert a new
device into the working area.
2. Click into the working area to insert a device.
The Insert new Node window appears.
3. Enter the height in which the WirelessHART device is located in the z box.
We recommend that you add 10 cm to the actual height in which the device is
located, because the antenna sticks out of the device. Furthermore, if adding
10 cm in height, you can make sure that the device is not located inside a wall
or ceiling, which might falsify the results.
If the device is located on a metal surface, we recommend that you add 30 cm
to the actual height, to take into account the reflection of the material.
4. Select the device type in the Object drop-down list, for example WHA GW for
a WirelessHART gateway.
5. To edit further details, such as the antenna position, click Edit Settings. See
chapter 5.11
6. Click OK to insert the device at the specified location.
The device icon is displayed in the working area.

Top view of the WirelessHART devices

2015-01

Figure 5.7
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5.10

Import Instrument List from WirelessHART Gateway
Instead of inserting the devices manually, you can import an instrument list from
the WirelessHART gateway.

Import Instrument List
1. You can use the web interface or the device type manager (DTM) of the WirelessHART gateway to create an instrument list. If using the DTM, you can also
choose Import Project Tree to import the devices from the PACTwareTM
project tree into the instrument list of the WirelessHART gateway. For more information, see the manual of the WirelessHART gateway.

Figure 5.8

Import project tree

2. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Instrument List and click Export CSV and save the
CSV file locally.
3. In WiNCSim choose File > Import > Object Data > Customer Specific >
Instrument List File and import the CSV file you exported from the
WirelessHART gateway.

Figure 5.9

Imported instrument list

4. To move the devices in the working area, use the
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Move Object button.
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The WirelessHART devices are inserted in the lower left corner of the
working area.
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5. To check the device properties and adjust the height in which the device is
located, right-click the device using the
Properties.

5.11

Select Objects tool and select

Edit WirelessHART Devices
Edit Device Parameters
1. Click
Edit Object in the Project Toolbar and click a device in the working
area or select a device in the working area, then right-click the device and select Properties.
The Node Configuration window appears.
2. Enter a name for the device in the Name box in the General area. The device
name is displayed in the working area.
3. To change the device type, select a device type from the Type drop-down list
in the General area.
4. To change the location of the WirelessHART device, for example, the height in
which the device is located, click Edit in the Location area.
The Location Configuration window appears.

Figure 5.10

Location Configuration window

5. Specify the coordinates of the device, for example the height in which the
device is mounted.
We recommend that you add 10 cm to the actual height in which the device is
located, because the antenna sticks out of the device. Furthermore, if adding
10 cm in height, you can make sure that the device is not located inside a wall
or ceiling, which might falsify the results.
If the device is located on a metal surface, we recommend that you add 30 cm
to the actual height, to take into account the reflection of the material.
Click OK to close the Location Configuration window.
6. To edit the antenna characteristics of a WirelessHART device, click Edit in the
Transceiver area.
The Transceiver Configuration window appears.
7. Make sure that the Enabled option in the General area is activated.
Otherwise the WirelessHART device is deactivated.

2015-01

8. The Transmitter and Receiver areas enable you to define detailed
transmission settings.
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9. To change the antenna type, select Directional Antenna or
Omnidirectional (Isotropic) Antenna in the Antenna area. Note that the
antenna types of the WirelessHART gateway, WirelessHART adapter, and
WirelessHART temperature converter are already predefined. For devices
using a bidirectional antenna, you can specify the antenna orientation in the
Orientation area.
10. Click OK to confirm the current settings and close the Transceiver
Configuration window.
11. Click OK to close the Node Configuration window.

5.12

Perform Simulations
After the working area has been configured and the WirelessHART devices have
been placed into the working area, you can start the simulation runs.

1. Network Prediction
indicates the overlapping of signals for a defined
height, for example, 18 m. Therefore, you must first calculate wave propagation of all signals for the desired height. To do so, calculate Wave
Propagation
for a selected area using the Dominant Path Model or the
Multi-Wall Model (COST 231).
2. Connectivity Prediction
is based on three-dimensional wave propagation. Therefore, you must first calculate three-dimensional wave propagation for each WirelessHART device. To do so, calculate Wave
for the node locations using 3D Standard Ray Tracing
2015-01

Propagation
(SRT).
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Network Prediction
Simulate Network
1. Click
Project Parameter in the Project Toolbar or choose Project > Parameter.
2. Select the Prediction tab.
3. Activate Total Area or Rectangular Area in the Simulation Area area.
4. Enter the height for which the results will be calculated in the Prediction
Height(s) box. You can also specify multiple heights at a time. Note that you
must use a dot as decimal separator and a space character to separate
multiple values.
5. Select Dominant Path Model or Multi-Wall Model (COST 231) in the
Prediction Model area.
6. Click OK.
7. Click
Compute Propagation to calculate wave propagation for the
selected height.
The calculation is in progress as long as the status bar displays Engine
Busy

.

8. After wave propagation has been calculated, click
choose Computation > Compute All > Network.

Compute Network or

The Output window on the bottom of the screen shows the progress of
the calculation.

Output window

2015-01

Figure 5.11
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Display Results
Note!
The results of previous simulations are not deleted automatically. Right-click the
result folder and click Erase Data before you perform a new simulation or if you
are using the same folder for different projects.
1. Use the File Browser on the left side of the screen to display the results.
2. To display wave propagation for a selected device, select a result from the
propagation folder.
The propagation for the selected device is displayed.

Figure 5.12

Wave propagation for individual devices

3. To display the entire network, select Max Received DL Power from the
network folder.
The network coverage is displayed.

Network prediction

2015-01

Figure 5.13
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Connectivity Prediction
Simulate Connectivity
1. Click
Project Parameter in the Project Toolbar or choose Project > Parameter.
2. Select the Prediction tab.
3. Activate Node Locations in the Simulation Area area and select the 3D
Standard Ray Tracing (SRT) model in the Prediction Model area.
4. Click OK.
5. Click
Compute Propagation to calculate three-dimensional wave
propagation for all devices.
The calculation is in progress as long as the status bar displays Engine
Busy

.

6. After wave propagation has been calculated, click
Compute
Connectivity or choose Computation > Compute All > Connectivity.
The Output window on the bottom of the screen shows the progress of
the calculation.

Output window

2015-01

Figure 5.14
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Display Results
Note!
The results of previous simulations are not deleted automatically. Right-click the
result folder and click Erase Data before you perform a new simulation or if you
are using the same folder for different projects.
1. Click File Browser on the left side of the screen.
The File Browser appears.

Figure 5.15

File Browser window

2. Open the network folder and select the WirelessHART Network
Connectivity entry.
3. Click

Show Paths in the Edit Toolbar or choose Edit > Show Paths.

4. Select a WirelessHART device in the working area to display its connections
to other devices.
The connections of the selected device are displayed.
In this example, you can see that the gateway is connected to three adapters
WHA ADP 2, WHA ADP 1, WHA ADP 5 via direct connections (blue
connection lines) and to three more adapters WHA ADP 4, WHA ADP 3,
WHA ADP 6 via indirect connections (green connection lines).

Connectivity prediction for WirelessHART gateway WHA GW
2015-01

Figure 5.16
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5. You can change the paths that are displayed by changing the Display
settings in the global settings. See chapter 5.6
For example, if you select Paths to gateway/router nodes and select the
adapter WHA ADP 6 you see that it is connected to the gateway via the
adpaters WHA ADP 3 and WHA ADP 1.

Figure 5.17

5.13

Connectivity prediction for WirelessHART adapter WHA ADP6

Analyze Results
Use the Color Legend
1. Use the File Browser on the left side of the screen to display the network results.
2. Make sure the color legend for the dBm ranges is available. If not, click
Show Legend to display the color legend.
3. Use the color legend to identify the transmitter power in a defined area.

Figure 5.18

Analyze results using the color legend
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Tip
You can customize the color legend in the global settings. See chapter 5.6
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Use the Status Bar
1. Use the File Browser to display the network results.
2. Move the cursor over the results in the working area. The status bar on the
bottom of the screen displays the exact dBm value for the current cursor
position. This enables you to determine more accurate values for any position
in the working area.

Figure 5.19

Analyze results using the status bar

Note!
Although the status bar provides more accurate results for any position, keep in
mind that the overall accuracy depends on the the resolution you defined in the
project parameters. See chapter 5.7

Define Signal Threshold
1. Use the File Browser to display the network results.
2. Click
Show Threshold in the Edit Toolbar or choose Edit > Show
Threshold.
The Received Power window appears.
3. Enter a threshold value in the Value box. Because the minimum required
signal level for the WirelessHART adapters is -85 dBm, you can for example
define a threshold of -75 bBm.
4. Click OK to close the Received Power window.
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The color legend in the working area and in the 3-D view are updated
automatically according to the defined threshold. Values above this threshold
are automatically displayed in green, values below are displayed in red.
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Figure 5.20

Analyze results using a customized color legend

Note!
All results must be considered in connection with the prediction height that you
specified in the project parameters.
In this example, the prediction height is above the small storage basins (10 m)
and the adapter (WHA-ADP 4) is on the ground (0 m). The storage basins are not
displayed in the working area, because they are not part of the prediction area,
but nevertheless they represent an obstacle for the signal of the adapter. The red
area indicates that the signal level is below the selected threshold.
WiNCSim enables you to calculate the results for multiple prediction heights at a
time. See chapter 5.7

Network prediction in a prediction height of 10 m

2015-01

Figure 5.21
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Use the Log File
1. Go to the result directory that you specified during the creation of the project.
See chapter 5.1
2. Open the network directory.
3. Open the MeshLinkData.txt log file.
This file contains detailed information on each network device, for
example the exact coordinates of the mounting positions, or information on
the connections to neighboring devices.

Figure 5.22

5.14

Log file

Export Instrument List and Topology View to the WirelessHART
Gateway
After you have determined the optimal position for each WirelessHART device,
you can export an updated instrument list for the WirelessHART gateway. In
addition to the instrument list, WiNCSim creates a second CSV file containing the
positions for each device.
Example!
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If you added additional devices during simulation, for example, if you added
several adapters that act as repeaters, you can easily import all devices into the
instrument list of the WirlessHART gateway. Furthermore, you can also update the
topology view by importing the CSV file with the device positions.

64

Wireless Network Checker
WiNCSim

Update Instrument List of the WirelessHART Gateway
1. In WiNCSim choose File > Export > Object Data > Customer Specific > Instrument List File.
WiNCSim automatically creates two CSV files. The first CSV file contains
the instrument list. The second CSV file is automatically gets the extension
Topology and contains the device positions.
2. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Instrument List and click Import CSV. Note that the
import will overwrite an existing instrument list.
All devices from the working area in WiNCSim have been transferred into
the instrument list of the WirelessHART gateway.

Update Topology View of the WirelessHART Gateway
1. Make sure you have the CSV file with the extension Topology that resulted
from the export of the instrument list. If not, choose File > Export > Object
Data > Customer Specific > Instrument List File in WiNCSim to create this
CSV file.
2. In WiNCSim choose File > Export > Map Data > Image File.
The Export to Image File window appears.
3. Enter the path and file name for the background image in the General area.
4. Select Export 2D View and Create Geo Reference for Image in the Export
area and click OK.
The current view of the working area is saved as an image with embedded
coordinates.
5. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Topology View.
6. Click Select Map and open the background image you exported using
WiNCSim.
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The background image is integrated into the topology view.
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Figure 5.23

Topology View with background image

7. Transfer the coordinates that are displayed in the lower left corner of the
background image into the Horizontal image origin, Vertical image origin,
and Resolution fields.

Coordinates for the image origin
2015-01

Figure 5.24
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8. Click Import CSV and open the CSV file with the extension Topology
containing the positions for each device.
The devices are automatically aligned according to the positions that have
been determined in WiNCSim.

WirelessHART devices have been aligned in the Topology View
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Figure 5.25
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6

WiNCSim Tutorial
This tutorial describes how to calculate network prediction and connectivity
prediction for the factory site created in WiNCMod.

Create a New Project
Note!
Note that you need a license key in order to handle large projects. If the WiNCMod
database is not displayed correctly, check if your USB hardware key is working
correctly.
We recommend that you select a display height for the working area that
intersects most objects. If you are missing an object in the working area, select
another display height. See chapter 5.6
1. Click

New Project or choose File > New Project.

2. Click Browse in the Databases & Parameters area.
3. Select a WiNCMod database file and click Open.
4. Click OK.
The WiNCMod database is displayed in the working area.

Figure 6.1

Top view

Insert Devices
Note!

1. Zoom into the working area. See chapter 3.9
68
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Note that you need a license key in order to insert multiple WirelessHART
devices. If you cannot insert a new device, check if your USB hardware key is
working correctly.
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2. Click
area.

Insert Object to insert a WirelessHART device into the working

The Insert new Node window appears.

Figure 6.2

Insert New Node window

3. Enter the height in which the WirelessHART device is located in the z box, for
example 10.10 m for the WirelessHART gateway, which is mounted on the
roof top of the storehouse (10 m).
We recommend that you add 10 cm to the actual height in which the device is
located, because the antenna sticks out of the device. Furthermore, if adding
10 cm in height, you can make sure that the device is not located inside a wall
or ceiling, which might falsify the results.
If the device is located on a metal surface, we recommend that you add 30 cm
to the actual height, to take into account the reflection of the material.
4. Select the device type in the Object drop-down list, for example WHA GW for
a WirelessHART gateway. See chapter 5.9
5. To edit further details, such as the antenna position, click Edit. See chapter
5.11
6. Click OK to insert the device at the specified location.
The device icon is displayed in the working area.

Top view of the WirelessHART devices
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Figure 6.3
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Import Devices from WirelessHART Gateway
Note!
Note that you need a license key in order to insert multiple WirelessHART
devices. If you cannot insert a new device, check if your USB hardware key is
working correctly.
1. You can use the web interface or the device type manager (DTM) of the WirelessHART gateway to create an instrument list. If using the DTM, you can also
choose Import Project Tree to import the devices from the PACTwareTM
project tree into the instrument list of the WirelessHART gateway.

Figure 6.4

Import project tree

2. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Instrument List and click Export CSV and save the
CSV file locally.
3. In WiNCSim choose File > Import > Object Data > Customer Specific >
Instrument List File and import the CSV file you exported from the
WirelessHART gateway.

Imported instrument list

The WirelessHART devices are inserted in the lower left corner of the
working area.
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Figure 6.5
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4. To move the devices in the working area, use the

Move Object button.

5. To check the device properties and adjust the height in which the device is
located, right-click the device using the
Properties.

Select Objects tool and select

Simulate Network
1. Click
Project Parameter in the Project Toolbar or choose Project > Parameter.
2. Select the Prediction tab.
3. Activate Total Area in the Simulation Area area.
4. Specify the height for which the results will be calculated, for example
10.10 m because the WirelessHART gateway is mounted in this height. Enter
the height in the Prediction Height(s) box in the Simulation Area area.
5. Select Dominant Path Model or Multi-Wall Model (COST 231) in the
Prediction Model area. See chapter 5.7
6. Click OK.
7. Click
Compute Propagation to calculate wave propagation for the
selected height.
The calculation is in progress as long as the status bar displays Engine
Busy

.

8. After wave propagation has been calculated, click
choose Computation > Compute All > Network.

Compute Network or

The Output window on the bottom of the screen shows the progress of
the calculation.

Output window
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Figure 6.6
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Simulate Connectivity
1. Click
Project Parameter in the Project Toolbar or choose Project > Parameter.
2. Select the Prediction tab.
3. Activate Node Locations in the Simulation Area area.
4. Select the 3D Standard Ray Tracing (SRT) prediction model. See chapter
5.7
5. Click OK.
6. Click
Compute Propagation to calculate three-dimensional wave
propagation for all devices.
The calculation is in progress as long as the status bar displays Engine
Busy

.

7. After wave propagation has been calculated, click
Compute
Connectivity or choose Computation > Compute All > Connectivity.
The Output window on the bottom of the screen shows the progress of
the calculation.

Output window
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Figure 6.7
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Analyze Results
1. Use the File Browser on the left side of the screen to display the results.
2. To display wave propagation for a selected device, select a result from the
propagation folder.
The propagation for the selected device is displayed.

Figure 6.8

Wave propagation for individual devices

3. To display the entire network, select Max Received DL Power from the
network folder.
The network coverage is displayed.

Figure 6.9

Network prediction

4. To display connectivity between the WirelessHART devices, open the
network folder and select the WirelessHART Network Connectivity entry.
5. Click

Show Paths in the Edit Toolbar or choose Edit > Show Paths.

6. Select a WirelessHART device in the working area.
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The connections of the selected device are displayed.
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Figure 6.10

Connectivity prediction for WirelessHART gateway WHA GW

Note!
You can change the display settings and the color palette for the results on the
Display and Display 3D tabs in the global settings. Click
Change Settings
or choose Edit > Settings to define the global settings. See chapter 5.6
Tip
Click
Show Threshold in the Edit Toolbar or choose Edit > Show
Threshold to define a signal threshold. Values above this threshold are
automatically displayed in green, values below are displayed in red.

Figure 6.11

Analyze results using a customized color legend

Save Project

2. Enter a file name and click Save.
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1. Choose File > Save As to save the project including the results of the simulations.
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Update Instrument List of the WirelessHART Gateway
1. In WiNCSim choose File > Export > Object Data > Customer Specific > Instrument List File.
WiNCSim automatically creates two CSV files. The first CSV file contains
the instrument list. The second CSV file is automatically gets the extension
Topology and contains the device positions.
2. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Instrument List and click Import CSV. Note that the
import will overwrite an existing instrument list.
All devices from the working area in WiNCSim have been transferred into
the instrument list of the WirelessHART gateway.

Update Topology View of the WirelessHART Gateway
1. Make sure you have the CSV file with the extension Topology that resulted
from the export of the instrument list. If not, choose File > Export > Object
Data > Customer Specific > Instrument List File in WiNCSim to create this
CSV file.
2. In WiNCSim choose File > Export > Map Data > Image File.
The Export to Image File window appears.
3. Enter the path and file name for the background image in the General area.
Select Export 2D View and Create Geo Reference for Image in the Export
area and click OK.
The current view of the working area is saved as an image with embedded
coordinates.
4. In the menu tree of the web interface or the DTM of the WirelessHART
gateway navigate to the Topology View.
5. Click Select Map and open the background image you exported using
WiNCSim.

2015-01

The background image is integrated into the topology view.
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Figure 6.12

Topology View with background image

6. Transfer the coordinates that are displayed in the lower left corner of the
background image into the Horizontal image origin, Vertical image origin,
and Resolution fields.

Coordinates for the image origin
2015-01

Figure 6.13
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7. Click Import CSV and open the CSV file with the extension Topology
containing the positions for each device.
The devices are automatically aligned according to the positions that have
been determined in WiNCSim.

WirelessHART devices have been aligned in the Topology View
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Figure 6.14
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