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LB8106*
Introduction

1 Introduction
This document describes how to integrate the GSE file of the LB Remote I/O 
System into Siemens SIMATIC PCS 7 and how to make the I/O data usable in the 
functional diagrams.
This document provides system-related information that is not included in the 
manual of the device itself.
Software and Hardware Revisions

The PFLBFB library enables easy connection of Pepperl+Fuchs remote I/O 
modules to SIMATIC PCS 7 via PROFIBUS. The library contains PCS 7 compliant 
function blocks, CFC driver modules, and the documentation. Furthermore, a 
support hotline is available.
The PFLBFB library is not part of the default library of the SIMATIC PCS 7 station.
To purchase the library for the LB/FB remote I/O system, contact Siemens AG in 
Karlsruhe.

Product Name Revision
Siemens SIMATIC PCS 7
CFC library PFLBFB

Com unit LB8106* FW 6.27
GSE file CGV61711.gse V 1.11

Contact: Roland Heid
Siemensallee 84
76187 Karlsruhe
Germany

Phone: +49 (721) 595 6380
Fax: +49 (721) 595 6383
E-Mail: function.blocks.industry@siemens.com
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2 Setup a New Project
Create a New Project in SIMATIC Manager
1. Open the SIMATIC Manager.
2. Choose File > New Project.

 The New Project window opens.

3. Enter a name for the new project in the Name field.
4. Select Project from the Type drop-down list.
5. To close the window, click OK.

 The project window for the new project is displayed.
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Setup the Components of the SIMATIC Station
1. Right-click the project root in the component view and choose Insert New Ob-

ject > SIMATIC 400 Station.

 A placeholder for the SIMATIC 400 station is added to the project.

2. Select the placeholder for the SIMATIC 400 station in the project tree.
3. Double-click Hardware in the right window pane.

 The HW Config window opens.
4. The components of the SIMATIC station can be found in the component 

catalog on the right side of the HW Config window. If the catalog is not 
displayed automatically, click Display Catalog  in the menu bar of the 
HW Config window.
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5. Recreate the components of the SIMATIC station in the HW Config window.
To do so, drag the components from the catalog to the workspace starting 
with the rack.
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3 Install GSE File
The first step in order to integrate a PROFIBUS slave into a PROFIBUS master 
system is the integration of the GSE file of the slave into the engineering system of 
the master application.
Install GSE File
1. Open the HW Config window.

If a SIMATIC station is already opened in the workspace, choose Station > 
Close to close all open stations before you continue.

2. Choose Options > Install GSD File.



LB8106*
Install GSE File

 20
13

-0
5

9

3. Select from the directory in the Install GSD Files drop-down list.
4. Click Browse and select the directory in which the GSE file is located.

 All GSE files from the selected folder are displayed in the Install GSD 
Files window.

5. Select the CGV61711.gse GSE file and click Install.

 The system notifies you that the installation of the GSE file cannot be 
undone.
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6. Click Yes to continue with the installation of the GSE file.
 The installation of the GSE file has been completed. Click OK to close the 

notification window.

7. After the installation of the GSE file has been completed, you can reopen the 
SIMATIC station you closed before the installation. To do so, choose Station 
and select the corresponding SIMATIC station.
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4 Configuration of the PROFIBUS Slave
4.1 Add Remote I/O Station to the Network

Add Remote I/O Station as a PROFIBUS Slave
1. To locate the remote I/O station, expand the component catalog on the right 

side of the HW Config window.

Note!
The PROFIBUS address of the remote I/O station must be set using a third party 
tool. For example, you can use the RIO Admin Tool to set the address via the 
service bus using a USB to RS485 converter, or you can use the T+H PROFIBUS 
CommDTM to set the address via PROFIBUS using xEPI.
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2. To add a remote I/O station to the bus line, drag the LB/FB 8x06 DP/DPV1 
Remote IO entry on the PROFIBUS bus line in the area on the left.

 The Properties window opens.

3. Select the PROFIBUS address of the remote I/O station from the Address 
drop-down list and click OK.
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4.2 Add Components of the Remote I/O Station
After you have added the remote I/O station to the PROFIBUS bus line, you can 
recreate the components of the remote I/O station by adding the corresponding 
remote I/O modules to the remote I/O station.
Add Remote I/O Modules of the Remote I/O Station
1. Select the remote I/O station in the HW Config window.

 The table on the bottom of the screen displays the components of the 
remote I/O station.

2. To locate the remote I/O modules, expand the component catalog on the right 
side of the HW Config window.

3. To recreate the components of the remote I/O station, drag and drop the 
corresponding remote I/O modules from the component catalog on the right 
side of the of the HW Config window to the table at the bottom of the HW 
Config window.
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4. Start with the COM: Cmd + Status + Mod.-status com unit that includes 
command, global status, and status register information. This diagnostic data 
is required for the CFC drivers.

5. Drag and drop the remaining remote I/O modules from the component catalog 
on the right side of the of the HW Config window to the table at the bottom of 
the HW Config window until you recreated all components of the remote I/O 
station.
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Note!
Note the following guidelines when setting up the structure of the remote I/O 
modules:

■ All GSE-based configurations use single width modules. Thus, double 
width modules that occupy two slots must be configured like a single width 
module, followed by an empty slot. Note that the last slot must not be an 
empty slot. If the last remote I/O module is a double width module, it is 
configured like a single width module and the following empty slot is 
omitted.

■ The configuration must start with the com unit, no matter if it is used with or 
without diagnostic data.

■ On LB backplanes that contain a second slot for a redundant com unit, 
slots 1 and 2 must be configured as empty slots and the numbering of the 
remote I/O modules starts with slot 3. For example, the redundant base 
backplane LB9022A provides 22 slots for remote I/O modules, numbered 
from 3 to 24.
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4.3 Configure the Remote I/O Modules
After the remote I/O modules have been added to the remote I/O station, the input 
and output addresses of each remote I/O module must be configured.
Configure the Remote I/O Modules
1. Select the remote I/O station in the HW Config window.

 The table on the bottom of the screen displays the components of the 
remote I/O station including their input and output addresses.
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2. To configure the address, double-click the table entry of the remote I/O 
module that you want to configure.

 The Properties window opens.

3. Depending on the type of the remote I/O module, you can define output 
address, input address, or both on the Address / ID tab.
Note that for remote I/O modules that process output and input data at the 
same time, the CFC drivers require the same start address for output and 
input, for example, for LB2* digital outputs with positioning feedback.

4. To edit the device-specific parameters, select the Parameter Assignment 
tab.
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5. Specify the exact module version for all remote I/O modules that are available 
in different versions, for example, for LB2* digital outputs with positioning 
feedback or LB6*1* digital outputs.

6. Click OK to confirm the selected parameters.
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5 Download Hardware Data to CPU
After the remote I/O station has been added to the PROFIBUS bus line and after 
all remote I/O modules have been configured, the hardware configuration must be 
downloaded to the CPU of the SIMATIC station.

Download Hardware Data to CPU
1. To translate the hardware configuration into a machine readable format, 

choose Station > Save and Compile in the HW Config window.

 The hardware configuration is compiled.

Note!
Note that the CPU will be stopped for the download process. After the download 
has been completed, the CPU must be restarted.
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2. Download the compiled data to the CPU of the SIMATIC station. The 
download can be performed in different ways, for example, via Ethernet or 
MPI (Multi Point Interface). In this case, the download is performed via 
Ethernet.
To download the compiled data to the CPU, click Download  in the menu 
bar or choose PLC > Download.

 The Select Target Module window opens.

3. Select the module to which you want to download the configuration data and 
click OK.

 The Select Node Address window opens.
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4. If required, enter the IP address of the Ethernet card in the SIMATIC rack and 
click OK.

 The Stop Target Modules window opens.

5. To confirm that the selected module will be stopped for the download process, 
click OK.

 The module is stopped and the Download window opens.

6. To restart the module, click Yes.
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6 Online Diagnostics

Access Diagnostic Data
1. To switch from Configuration mode to ONLINE mode, click the toggle 

button  in the menu bar of the HW Config window.
 You are now in ONLINE mode.

2. Double-click the remote I/O station in the HW Config window.
3. To access basic diagnostic information of the remote I/O station, select the 

DP Slave Diagnostics tab.
 The latest diagnostic information is displayed.

Note that this window contains only information that could be interpreted by 
SIMATIC using the information from the GSE file.
If required, click Update to update the diagnostic information.

4. To access additional diagnostic information that could not be interpreted 
using the information from the GSE file, click Hex.Format... on the DP Slave 
Diagnostics tab.
For more information on how to interpret the diagnostic information in 
hexadecimal format, see chapter 9.

Note!
Diagnostic information is available in ONLINE mode only.
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7 Monitor/Modify Raw Data
If required, you can monitor or modify the PROFIBUS data directly from the 
PROFIBUS interface, without having the data adjusted by the SIMATIC station.
Monitor/Modify PROFIBUS Data
1. Select the remote I/O station in the HW Config window.

 The table on the bottom of the screen displays the components of the 
remote I/O station including their input and output addresses.

2. Right-click the component from which you want to monitor or modify the raw 
data and choose Monitor/Modify from the context menu.

 The Monitor/Modify window for the address range of the selected 
component opens.
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3. To display the input respectively output data, activate the Monitor check box 
in the Run conditionally area.

 The entries for each address will be updated automatically.
4. To modify an output value, enter the new value in the corresponding line of the 

Modify Value column and click Modify Value.
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8 Programming the PLC
There are several different programming languages for programming the PLC:

■ Statement List (STL) also referred to as Instruction List (IL)
■ Ladder Logic (LAD)
■ Function Block Diagram (FBD)

The following chapters describe how to program the PLC using Continuous 
Function Charts (CFC) that are based on the Function Block Diagram (FBD) 
language.

8.1 Add Chart
To program the PLC using Continuous Function Charts (CFC), you must first add 
a Chart Object to the S7 Program.
Add CFC Object
1. Right-click the S7 Program folder in the SIMATIC Manager and choose In-

sert New Object > CFC.

 A new chart is added to the Charts subfolder of the S7 Program folder.
2. Enter a name for the chart.

Note!
The CFC functionality is available as a SIMATIC Step 7 package.
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8.2 Add Library
The PFLBFB library enables easy connection of Pepperl+Fuchs remote I/O 
modules to SIMATIC PCS 7 via PROFIBUS. The library contains PCS 7 compliant 
function blocks, CFC driver modules, and the documentation. Furthermore, a 
support hotline is available.
The PFLBFB library is not part of the default library of the SIMATIC PCS 7 station.
To purchase the library for the LB/FB remote I/O system, contact Siemens AG in 
Karlsruhe.

Add Library for LB/FB Remote I/O System
1. Save the library to a local directory on your computer.
2. Choose File > Open... in the SIMATIC Manager.
3. To open a library, select the Libraries tab and click Browse...

Contact: Roland Heid
Siemensallee 84
76187 Karlsruhe
Germany

Phone: +49 (721) 595 6380
Fax: +49 (721) 595 6383
E-Mail: function.blocks.industry@siemens.com

Note!
The screenshots in the following sections are based on version 4.1 of the 
CEAG_RED library, which is an older version of the PFLBFB library. We 
recommend that you use the PFLBFB library.
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4. Enter the path of the directory that contains the library for the LB/FB remote 
I/O system in the Find in directory field and click Select.

5. Click Start Search, select the library on the Libraries tab and click OK.
 The selected library opens in a separate window.

6. Select all blocks of the library and drag them into the Blocks subfolder of the 
S7 Program folder.
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8.3 Configure Charts
After you have added the function blocks from the library to the S7 Program, you 
can configure the Continuous Function Chart (CFC) using the CFC editor.
Configure Chart using the CFC Editor
1. Open the Charts subfolder of the S7 Program folder in the SIMATIC Manag-

er.
2. To open the CFC editor, right-click the chart you created before and choose 

Open Object.

 The CFC window opens.
3. Select the Libraries tab on the left side of the CFC window.
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4. Expand the library for the LB/FB remote I/O system in the library tree. In this 
example it is the CEAG_RED_V41_FC501 library.

5. Drag the CEAGRACK function block from the library into the chart area on the 
right. This function block represents the remote I/O station with the com unit.

6. Set the subnet ID (number of the DP master system) and the rack number 
(PROFIBUS address) for the CEAGRACK function block.
Note that you can find this information in the HW Config window.

7. Proceed with the function blocks for the remaining I/O modules that are 
contained in the remote I/O station.
For example, drag the C_BO2X12 function block from the library into the chart 
area on the right. This function block represents LB2* digital outputs with 
positioning feedback.
Watch the distance between the function blocks in the chart area. The 
restricted areas around each block are highlighted while moving the block in 
the chart area.
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8. Set the module number (slot number) for the C_BO2X12 function block.
Note that you can find this information in the table that displays the 
components of the remote I/O station on the bottom of the HW Config 
window.

9. Drag the CONNECT field of the CEAGRACK function block to the RACK_CON 
field of the C_BO2X12 function block. This connects the CEAGRACK function 
block to the C_BO2X12 function block.
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8.4 Compile Charts
To translate the Continuous Function Chart (CFC) into a machine readable format, 
the CFC must be compiled before it can be processed by the CPU.
Compile Charts as Program
1. Click Compile  in the menu bar of the CFC editor.

 The Compile program window opens.

2. Disable the Generate module drivers check box and click OK.
 The compilation process starts. After the compilation has been 

completed, the Logs window opens.

3. Check the compilation log for errors.
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8.5 Download Program to CPU
If the program has been compiled without errors, you can download the program 
to the CPU of the SIMATIC station.

Download Program to CPU

1. Click Download  in the menu bar of the CFC editor.
 The Download window opens.

2. To start the download process, click OK.
 The Download to CPU window opens.

3. To restart the CPU after the download has been completed, click Yes.

Note!
If you download the entire program, the CPU will be stopped for the download 
process. After the download has been completed, the CPU must be restarted.
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8.6 Test Signals
Once the program has been downloaded to the CPU you can switch to test mode 
and check the signals directly in the CFC editor.

Test Signals in CFC Editor

1. To switch the CFC editor to ONLINE mode, click Test Mode  in the menu 
bar of the CFC editor.

2. To visualize the signals of a function block, right-click the function block and 
choose Watch On or select the function block and click Watch On  in the 
menu bar of the CFC editor.

 The chart area displays the signals for the selected function block, in this 
example the C_BO2X12 function block.

Note!
Information on signals is available in ONLINE mode only.
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9 Appendix
Diagnostic Information

Hexadecimal Format Description
PROFIBUS Standard Diagnostics

Master Address

PROFIBUS ID

Length of device-specific 
diagnostics incl. header byte

Global status register of active 
com unit

Standard PROFIBUS diagnostics 
of passive com unit

Global status register of passive 
com unit

Additional 12 bytes of device-
specific diagnostics
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Device-Specific Diagnostics

Channel-Specific Diagnostics
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